ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Boisvert" <boisv...@intalio.com>
Subject Re: NullPointerException at process deployment
Date Mon, 03 Dec 2007 16:13:47 GMT
On 12/3/07, SŽebastien Mosser <mosser@polytech.unice.fr> wrote:
>
> Matthieu Riou a écrit :
> > Mmmh also your GetConvertedStockValueService doesn't appear to have a
> > GetConvertedStockValue port. Seems to me that the port should be
> > ConvertedStock_SOAP.
>
> Great, I think I'm reached the end of the tunnel :
>      <provide partnerLink="client">
>         <service name="tns:GetConvertedStockValueService"
> port="ConvertedStock_SOAP"/>
>       </provide>
>
>       <invoke partnerLink="Stock">
>         <service name="stock:StockService"
> port="StockServiceSOAP11port_http" />
>       </invoke>
>
>        <invoke partnerLink="Convert">
>         <service name="convert:ConverterService"
> port="ConverterServiceSOAP11port_http" />
>       </invoke>
>
> Now generate a :
> Caused by: java.lang.IllegalArgumentException: No service name for
> myRole plink Convert
>
> So it's a problem in my WSDL description ?


Hmmm.... I think this is the problem:

<bpws:partnerLink myRole="ConverterProvider" name="Convert"
                  partnerLinkType="ns:ConverterPartner"
partnerRole="ConverterProvider"/>

I don't think you need the "myRole" here since you're not providing this
service.

alex

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message