ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou" <matth...@offthelip.org>
Subject Re: doXslTranform not working
Date Wed, 24 Oct 2007 15:02:23 GMT
On 10/24/07, vikas cv <vikas.cv@gmail.com> wrote:
>
> Hi Matthieu,
>
> Thank you for the XSL sample. It works fine.
> I now have a different problem. When I make use of the doXslTransform in
> my
> BPEL process with proper mentions to queryLanguage to xpath2.0 and run the
> process, I get "could not find XSL style sheet" error. But, the XSL file
> is
> right there in the project folder, and it even gets deployed onto Ode
> without any error.
>
> Here's the actual Ode log:
> 18:47:26,063 ERROR [ASSIGN] Assignment Fault: {
> http://docs.oasis-open.org/wsbpel
> /2.0/process/executable}selectionFailure,lineNo=130,faultExplanation=An
> exceptio
> n occured while evaluating "{OXPath10Expression
> bpws:doXslTransform("borr_info_t
> o_borr_info_rep.xsl",$getBorrowersOutput.part)}": Error while executing an
> XPath
> expression: javax.xml.xpath.XPathFunctionException: Couldn't find the XSL
> sheet
> borr_info_to_borr_info_rep.xsl, process compilation or deployment was
> probably
> incomplete!


Do you use relative path? How does your doXslTransform call looks like?

Cheers,
Matthieu

Please let me know what is wrong.
>
> Thanks
> Vikas
>
> On 10/11/07, Matthieu Riou <matthieu@offthelip.org> wrote:
> >
> > Hi Vikas,
> >
> > The problem is that TestXslTransform is part of our test harness and not
> > really a sample so it was not completely built to be deployable. I've
> > fixed
> > it so that it can be deployed as well, you can get it here:
> >
> >
> >
> http://svn.apache.org/repos/asf/ode/branches/APACHE_ODE_1.1/bpel-test/src/test/resources/bpel/2.0/TestXslTransform/
> >
> > However the doXslTransform function works, the test itself passes
> without
> > any difficulty. Also it seems that your attachment hasn't gone through
> so
> > I
> > can't check your BPEL but hopefully with the deployable test case you'll
> > figure it out.
> >
> > Thanks,
> > Matthieu
> >
> > On 10/11/07, vikas cv <vikas.cv@gmail.com> wrote:
> > >
> > > Hi,
> > >
> > > I'm trying the XSL transform in Ode. To begin with, the sample
> > > "TestXslTransform" does not deploy on Ode. And when I created a new
> BPEL
> > > process to do the same Xsl Transform, I get "No such function
> > > doXslTransform" error on running the BPEL process. I tried removing
> the
> > > "bpws" namespace prefix as well, but with no success.
> > >
> > > I'm attaching the BPEL process and the relevant files. Please let me
> > know
> > > if
> > > Ode supports the function, what its usage is and what might be wrong
> in
> > my
> > > BPEL.
> > >
> > > Thanks & Regards
> > > Vikas
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message