ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cwik, Jan" <Jan.C...@sabre-holdings.com>
Subject RE: Timeout on JBI message exchange for ODE 1.1
Date Fri, 19 Oct 2007 13:48:35 GMT
thanks! I set up "org.apache.ode.jbi.sendSynch" to "true" and it works
fine.

regards
jan 

-----Original Message-----
From: Alex Boisvert [mailto:boisvert@intalio.com] 
Sent: Friday, October 19, 2007 2:55 PM
To: user@ode.apache.org
Subject: Re: Timeout on JBI message exchange for ODE 1.1

On 10/19/07, Cwik, Jan <Jan.Cwik@sabre-holdings.com> wrote:
>
> I'm trying to use ODE 1.1 together with fuse-3.2.0-SNAPSHOT but
> immediately after invoking the very first service I'm getting "Timeout
> on JBI message exchange". When I'm using ODE 1.0 it works fine. Is it
a
> known issue ?


Looks like the async jbi invocation is broken (minor logic problem).
I've
created a tracker for this issue,
https://issues.apache.org/jira/browse/ODE-198

In the mean time, you can use the synchronous invocation by setting the
system property "org.apache.ode.jbi.sendSynch" to "true".  I generally
recommend using JBI synchronous invokes unless you've determined that
you
have a scalability problem at the messaging layer, e.g. many outstanding
invokes taking a lot of time.   In my experience, synchronous makes the
system easier to debug, more stable under load and slightly faster for
the
general case since it incurs no context-switching cost.

alex

Mime
View raw message