ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fscavo <frank.sc...@baesystems.com>
Subject <assign> Activity Copying from a Literal Value Fails to Compile
Date Tue, 09 Oct 2007 01:39:47 GMT

Hello,

I'm trying to get a BPEL 1.1 process that ran great in PXE 1.0RC2B0001 to
deploy in ODE 1.1.  There seems to be a bug in the <assign> activity when
copying from a literal value.  For example this snippet:

    <process ...
        xmlns="http://schemas.xmlsoap.org/ws/2003/03/business-process/"
        xmlns:tns="http://services.baesystems.com/"
    >
        .
        .
        .
        <assign name="initialize_holder">
            <copy>
                <from>
                    <tns:holder>
                        <tns:imageTime/>
                        <tns:imageURI/>
                    </tns:holder>
                </from>
                <to variable="holder" part="payload"/>
            </copy>
        </assign>

fails to compile with the following error:

org.apache.ode.bpel.iapi.ContextException: Deploy failed; error:
[CompilationErrors] Compilation completed with 1 error(s):
        error: [UnkownFromSpec] From-spec format is unrecognized.

Other than porting to BPEL 2.0, does anyone know of a fix or a workaround
for this?  Note that borrowing <literal> from BPEL 2.0 doesn't work.

Thanks for your help,
Frank

-- 
View this message in context: http://www.nabble.com/%3Cassign%3E-Activity-Copying-from-a-Literal-Value-Fails-to-Compile-tf4591642.html#a13107902
Sent from the Apache Ode User mailing list archive at Nabble.com.


Mime
View raw message