ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jbi joe <...@daggerpoint.net>
Subject Re: xpath query has no effect during copy
Date Sun, 19 Aug 2007 09:23:14 GMT


I did make a typo here and didnt put my <to> block correctly...  OOOPs..

My goal is to modify the first level by appending to it.. WIthout Clobbering
the remainder of the XML.     I did see in the ODE documentation that the
"insert" wasnt BPEL.  However, I see others with extensions to their
engines,
, i.e. Oracle - BPELX ...

TIA


Matthieu Riou-5 wrote:
> 
> Hi,
> 
> So yes, the assignment is a bit weird. First the insert attribute is not
> part of BPEL. We've discussed of maybe implementing something along these
> lines but we're still pondering other solutions so it may very well never
> be
> implemented.
> 
> For the assignment itself, first your query element is outside of the <to>
> (should be inside). Also if what you want is a literal assignment then you
> should enclose your <from> in a <literal> element. So you would get
> something like:
> 
> <assign>
>   <copy>
>     <from><literal>'hardcode xml
> value=<key>address</address>'<literal></from>
>     <to variable="input" part="msg">
>       <query>//*[node()='level1']</query>
>     </to>
>   </copy>
> </assign>
> 
> Note that this will still replace the content of the <level1> element. If
> you want to iteratively fill up the element you'll have to use the
> doXslTransform function with an XSL sheet. Could you also give us more
> detail about your use case? Are you trying to add a set of elements from a
> list into another set of elements? Or are your element coming one by one
> from a service call for example?
> 
> Thanks,
> Matthieu
> 
> On 8/17/07, Jackson, Douglas <djackso2@ugs.com> wrote:
>>
>>
>> Hi!
>> I don't know if what you were writing is some new 2.0 syntax or not, but
>> in 1.0 you would write it like this:
>>
>> <to variable="input" part="msg" query="//*[node()='level1']"/>
>> -Doug.
>>
>> -----Original Message-----
>> From: jbi joe [mailto:joe@daggerpoint.net]
>> Sent: Friday, August 17, 2007 5:21 AM
>> To: user@ode.apache.org
>> Subject: xpath query has no effect during copy
>>
>>
>> MY XML INPUT TO BPEL
>>
>> <msg>
>> <level1>
>> <key>name</name>
>> <value>foo</value>
>> </level1>
>> <level2>
>> ...
>> ..
>> </level2>
>> </msg>
>>
>> <assign>
>> <copy insert="after">
>> <from>'hardcode xml value=<key>address</address>'</from>
>> <to variable="input" part="msg">
>> </to>
>> <query>//*[node()='level1']</query>
>> </assign>
>>
>> ALWays clobbers my entire xml between the <msg> node and inserts the
>> aboutve
>> value.
>> Anyone tell me what I have wroing?
>> TIA
>>
>> --
>> View this message in context:
>> http://www.nabble.com/xpath-query-has-no-effect-during-copy-tf4284882.ht
>> ml#a12197226
>> Sent from the Apache Ode User mailing list archive at Nabble.com.
>>
>>
> 
> 

-- 
View this message in context: http://www.nabble.com/xpath-query-has-no-effect-during-copy-tf4284882.html#a12220548
Sent from the Apache Ode User mailing list archive at Nabble.com.


Mime
View raw message