ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jens Goldhammer <Goldhammer.J...@gmx.net>
Subject Re: Building of ODE with Buildr failed...
Date Tue, 31 Jul 2007 15:29:04 GMT

This works for me. But I think, I cannot build ode correct. The output of

rake TEST=no package

works fine for me, no errors (a few warnings- Is there a logfile for the
building to analyze it?).
There are only the docs and sources of ode as zip-file in the target-folder,
but I cannot see the war-file. Where is it? Or does something fail then?

The testcases donĀ“t work for me. I am getting errors, the same exception for
deploying a process in tomcat6 (see thread
http://www.nabble.com/Apache-Tomcat-6%2C-Apache-ODE%2C-Example-HelloWorld2-tf4170153.html

and
http://www.nabble.com/Hellowolrd2-BPEL-process-Compile-Error-on-deploy-tf3241393.html)
What causes this error with the namespaces?Classpath problem? Libary
problem? Can anybody evaluate this? It would be great...

Can I reset the builded files (target folders) of rake automatically? I have
commandline-svn and tortoisesvn. Is there a command for it?

Thanks in advance,
Jens






Matthieu Riou-2 wrote:
> 
> Jens,
> 
> For the Zlib:BufError, you need to upgrade RubyGems. Just type the
> following
> and then installation should work properly:
> 
> gem update --system
> 
> I've updated the building guide with a troubleshooting section, thanks for
> mentioning it!
> 
> Cheers,
> Matthieu
> 
> On 7/30/07, Jens Goldhammer <Goldhammer.Jens@gmx.net> wrote:
>>
>>
>>
>>
>> Tammo van Lessen wrote:
>> >
>> > Jens,
>> >
>> > 2007/7/30, Jollero <Goldhammer.Jens@gmx.net>:
>> >> - I fix wrong buildr version (at the beginning)
>> > 1.1.3 is not the wrong version, it's currently the only version that
>> > works with Ode.
>> >
>> >> Is that documentated? I have found no information according to this...
>> >
>> > Therefore, please try to install 1.1.3 by running:
>> > gem install buildr -v1.1.3
>> >
>> >> While executing it, I get an buffer error ERROR: While Executing
>> gem...
>> >> (Zlib:BufError) buffer error
>> >
>> > You might run into some trouble with the net-ssh dependency - if this
>> > is the case, please post here again, in the meanwhile I'll try to
>> > upgrade the Ode build to the most recent buildr version.
>> >
>> >> Yes, it is the case. What can I do??
>> >
>> > Best,
>> >   Tammo
>> >
>> > Thanks Tammo,
>> > Jens
>> >
>> >
>>
>> --
>> View this message in context:
>> http://www.nabble.com/Building-of-ODE-with-Buildr-failed...-tf4169237.html#a11863683
>> Sent from the Apache Ode User mailing list archive at Nabble.com.
>>
>>
> 
> 

-- 
View this message in context: http://www.nabble.com/Building-of-ODE-with-Buildr-failed...-tf4169237.html#a11926393
Sent from the Apache Ode User mailing list archive at Nabble.com.


Mime
View raw message