ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pbax2007 <joel_antony2...@yahoo.com>
Subject Re: error building the latest Apache ODE (1.1) using Ruby
Date Wed, 25 Jul 2007 22:05:09 GMT

thanks Matthieu, by changing the proxy settings in directly in the ode rake
file , it picks up , and  builds successfully.

 



Matthieu Riou-2 wrote:
> 
> Hi Joel,
> 
> Thr problem is apparently with the proxy settings. Try to place the
> repositories.proxy definition directly in the ODE rakefile, to be sure
> it's
> properly picked up. Also make sure that the server address you gave as
> proxy
> host is valid.
> 
> Cheers,
> Matthieu
> 
> On 7/20/07, pbax2007 <joel_antony2001@yahoo.com> wrote:
>>
>>
>> Hi,
>> Iam new to apache ode, Here is my task, am trying to build the apache ode
>> (1.1) using ruby, after installing all the gems when i try to build the
>> ode
>> using the command
>> "rake TEST=no package" , it gives the following error. I welcome all
>> valuable suggestions
>>
>> C:\apacheOde>rake TEST=no package
>> (in C:/apacheOde)
>> Downloading org.apache.openjpa:openjpa-all:jar:0.9.7-incubating
>> getaddrinfo: no address associated with hostname.
>> getaddrinfo: no address associated with hostname.
>> getaddrinfo: no address associated with hostname.
>> getaddrinfo: no address associated with hostname.
>> rake aborted!
>> Failed to download org.apache.openjpa:openjpa-all:jar:0.9.7-incubating,
>> tried the following repositories:
>> http://pxe.intalio.org/public/maven2
>> http://people.apache.org/repo/m2-incubating-repository
>> http://repo1.maven.org/maven2
>> http://people.apache.org/repo/m2-snapshot-repository
>> C:/apacheOde/rakefile:316
>> (See full trace by running task with --trace)
>>
>> C:\apacheOde>
>>
>>
>> Here is the step i followed .
>>
>> Installed ruby .
>> get all the gem file and installed them in the beolow order.
>>
>> 1. gem_name=rake (v. 0.7.3)
>>
>>
>> 2. game_name=facets v. 1.8.54
>>
>>
>> gem_name=builder (v. 2.1.1)
>>
>> gem_name=needle (v. 1.2.0)
>>
>>
>> gem_name=net-ssh (v. 1.1.1)
>> gem_name=net-sftp (v 1.1.0)
>>
>>
>> gem_name=rubyzip (v. 0.9.1)
>>
>> gem_name=highline (v. 1.2.7)
>>
>> rjb 1.0.4
>> gem_name=Antwrap (v. 0.5.2)
>>
>> gem_name=buildr (v. 1.1.3)
>>
>>
>> Create a file named buildr.rake , and added the proxy sttings.
>> repositories.proxy = {:host=>"proxy_host", :port=>"proxy_port",
>> :user=>"user_name", :password=>"user_password"}
>>
>>
>>
>> I try using the latest version of rjb 1.0.6.and when doing the build
>> using
>> the command "rake TEST=no package",
>> it ask to edit the buildr.rake file and set the proxy as options.proxy,
>> but
>> after doing the build again it says options is undefind.
>>
>>
>>
>> Please advise where i am went wrong ?
>>
>>
>> thanks in advance
>>
>> joel
>>
>>
>> --
>> View this message in context:
>> http://www.nabble.com/error-building-the-latest-Apache-ODE-%281.1%29-using-Ruby-tf4117330.html#a11708891
>> Sent from the Apache Ode User mailing list archive at Nabble.com.
>>
>>
> 
> 

-- 
View this message in context: http://www.nabble.com/error-building-the-latest-Apache-ODE-%281.1%29-using-Ruby-tf4117330.html#a11800819
Sent from the Apache Ode User mailing list archive at Nabble.com.


Mime
View raw message