ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luca Clementi <l.cleme...@cineca.it>
Subject Re: problems with xpath selection
Date Sat, 02 Jun 2007 20:48:54 GMT


Alex Boisvert wrote:
> Hi Luca,
> 
> Indeed this looks like a bug in the BPEL 1.1. compatibility area....  for
> now I'd recommend using the BPEL 2.0 syntax ($variable.part/...)
> 
> Can you file a Jira issue?   That way, it will get on our TODO list.
> 
> thanks for reporting,
> alex
> 

Done.
Maybe just reporting this in some part of the documentation can save 
time to other people, while it is not fixed.

Sincerely,
Luca



-------- Original Message --------
Subject: [jira] Created: (ODE-143) bug in the BPEL 1.1/2.0 compativility 
in copying variables
Date: Sat, 2 Jun 2007 13:40:15 -0700 (PDT)
From: Luca Clementi (JIRA) <jira@apache.org>
To: l.clementi@cineca.it

bug in the BPEL 1.1/2.0 compativility in copying variables
----------------------------------------------------------

                  Key: ODE-143
                  URL: https://issues.apache.org/jira/browse/ODE-143
              Project: Ode
           Issue Type: Bug
           Components: BPEL Runtime
     Affects Versions: 1.0-incubating, Incubator, 1.1-incubating
          Environment: Java 5
ServiceMIX 3.2-incubating-SNAPSHOT
             Reporter: Luca Clementi


There is a problem when copying variables.

if the old BPEL 1.0 format is used to select variables parts e.g.:
<from variable="variable_name" 
part="variable_part"><query>query</query></from>
<to variable="variable_name" part="variable_part"><query>query</query></to>
the behavior of the engine is not correct, it select randomly the 
variable's parts.


While if the other format is used (BPEL 2.0) the assign works properly, 
for example:
<from>$variable_name.variable_part/query</from>
<to>$variable_name.variable_part/query</to>

Luca



Mime
View raw message