ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alex Boisvert" <boisv...@intalio.com>
Subject Re: Ode build failing: Artifact org.apache.ode:xalan:jar:2.7.0 not found
Date Fri, 04 May 2007 14:26:52 GMT
I agree the <id> of the repository should be different.   I'll change it
unless somebody thinks it should remain "central".   Any considerations for
not doing so?

alex


On 5/4/07, Michael Horwitz <mike.horwitz@gmail.com> wrote:
>
> I see the problem - the PXE repository is defined with the id 'central'
> which clashes with the default Maven repository. We use a maven proxy, and
> have the following in our settings.xml (this could be fairly common for
> maven builds):
>
>   <mirrors>
>    <mirror>
>      <id>archiva_central_mirror</id>
>      <name>Archiva Central Mirror</name>
>      <url>...</url>
>      <mirrorOf>central</mirrorOf>
>    </mirror>
> </mirrors>
>
> So the PXE repo gets bypassed....... May be worth sticking a note on the
> Wiki?
>
> Thanks
>
> Mike Horwitz
>
>
> On 5/4/07, Matthieu Riou <matthieu.riou@gmail.com> wrote:
> >
> > Hi,
> >
> > Just for clarifications, we have our own Xalan version (which is
> strictly
> > identical to the distribution) because Maven repositories contain a
> rather
> > "partial" version of it.
> >
> > Cheers,
> > Matthieu
> >
> > On 5/4/07, Alex Boisvert <boisvert@intalio.com> wrote:
> > >
> > > You can find it here:
> > > http://pxe.intalio.org/public/maven2/org/apache/ode/xalan/2.7.0/
> > >
> > > The pxe.intalio.org repository should be listed in the Maven2 pom.xml.
> > >
> > > alex
> > >
> > >
> > > On 5/4/07, Michael Horwitz <mike.horwitz@gmail.com> wrote:
> > > >
> > > > Hi,
> > > >
> > > > I have tried downloading and building Ode as per the instructions,
> but
> > > the
> > > > Maven build bombs out on ode-utils when it tries to find the
> artifact
> > > > org.apache.ode:xalan:jar:2.7.0.
> > > >
> > > > Is this a special version of Xalan for Ode? If so where can I get
> the
> > > > artifact so I can get the build working?
> > > >
> > > > Thanks
> > > >
> > > > Mike Horwitz
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message