ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wolfgang10 <m...@pleus.net>
Subject Re: Error invoking jbi ODE inside servicemix
Date Fri, 23 Feb 2007 17:06:16 GMT

Your example works fine. Thank you for providing it.
Wolfgang


Hi All,

I have added a comment with an attachment to the ODE-99 issue.
The example I have posted works for me.
I have made various mistakes related to the format of the soap message and
the wsdl associated to the BPEL process.
In particular this is the correct input message  for the BPEL process :

<?xml version="1.0" encoding="UTF-8"?>
<soapenv:Envelope
xsi:schemaLocation="http://schemas.xmlsoap.org/soap/envelope/
http://schemas.xmlsoap.org/soap/envelope/"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
xmlns:test="test.wsdl"
xmlns:typens="http://samples.aware.org/types"
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:sam="http://samples.aware.org/EchoSchema">
  <soapenv:Body>
    <typens:invokeRequest>
      <typens:s>test message</typens:s>
    </typens:invokeRequest>
  </soapenv:Body>
</soapenv:Envelope>

and this is the correct wsdl :

<?xml version="1.0" encoding="UTF-8"?>
<wsdl:definitions 
    targetNamespace="test.wsdl" 
    xmlns:pln="http://schemas.xmlsoap.org/ws/2004/03/partner-link/" 
    xmlns:sam="http://samples.aware.org/EchoSchema" 
    xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
    xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/" 
    xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/" 
    xmlns:typens="http://samples.aware.org/types"
    xmlns:test="test.wsdl" 
    xmlns="http://schemas.xmlsoap.org/wsdl/">

<wsdl:types>
    <xsd:schema targetNamespace="http://samples.aware.org/types"
elementFormDefault="qualified">
        <xsd:element name="invokeRequest">
                <xsd:complexType>
                    <xsd:sequence>
                        <xsd:element name="s" type="xsd:string"
minOccurs="0"/>
                    </xsd:sequence>
                </xsd:complexType>
        </xsd:element>

        <xsd:element name="invokeResponse">
                <xsd:complexType>
                    <xsd:sequence>
                        <xsd:element name="return" type="xsd:string"
minOccurs="0"/>
                    </xsd:sequence>
                </xsd:complexType>
        </xsd:element>
    </xsd:schema>
  </wsdl:types> 

  <wsdl:message name="invokeResponse">
    <wsdl:part name="body" element="typens:invokeResponse">
    </wsdl:part>
  </wsdl:message>
  <wsdl:message name="invokeRequest">
    <wsdl:part name="body" element="typens:invokeRequest"> 
    </wsdl:part>
  </wsdl:message>

  <wsdl:portType name="invokePT">
    <wsdl:operation name="invokeRequest">
     <wsdl:input message="test:invokeRequest">
     </wsdl:input>
     <wsdl:output message="test:invokeResponse">
     </wsdl:output>
    </wsdl:operation>
  </wsdl:portType>

  <pln:partnerLinkType name="test_partnerLinkType0">
    <pln:role name="invokePTRole" portType="test:invokePT"/>
  </pln:partnerLinkType>

  <pln:partnerLinkType name="test_partnerLinkType1">
    <pln:role name="EchoService" portType="sam:EchoPT"/>
  </pln:partnerLinkType> 
</wsdl:definitions>

Claudio


I've created one. The issue is ODE-99.

https://issues.apache.org/jira/browse/ODE-99

Wolfgang


Alex Boisvert wrote:
> 
> If one of you two can create Jira issue and attach a standalone service
> assembly zip, I'll take a good look at it.
> 
> alex
> 
> 

-- 
View this message in context: http://www.nabble.com/Error-invoking-jbi-ODE-inside-servicemix-tf3027855.html#a9122627
Sent from the Apache Ode User mailing list archive at Nabble.com.


Mime
View raw message