ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wolfgang10 <m...@pleus.net>
Subject Re: Error invoking jbi ODE inside servicemix
Date Fri, 23 Feb 2007 07:50:33 GMT

I've created one. The issue is ODE-99.

https://issues.apache.org/jira/browse/ODE-99

Wolfgang


Alex Boisvert wrote:
> 
> If one of you two can create Jira issue and attach a standalone service
> assembly zip, I'll take a good look at it.
> 
> alex
> 
> 
> On 2/22/07, wolfgang10 <mail@pleus.net> wrote:
>>
>>
>> Claudio,
>>
>> Did you find a solution for the problem? I have the same.
>>
>> Wolfgang
>>
>>
>> claudio cacciari wrote:
>> >
>> > Alex Boisvert wrote:
>> >> Hi Claudio,
>> >>
>> >> How are you sending the message to Ode?
>> >
>> > I have created a SA containing the following SUs :
>> >
>> > JSR181 : that implements the EchoService .
>> > HTTP : to expose the EchoService outside the bus.
>> > ODE : for the test.bpel.
>> > Ode - HTTP : to expose the TestService outside the bus.
>> >
>> > this is the xbean related to the ode http su (TestService-HTTP + SOAP)
>> :
>> >
>> > <beans xmlns:http="http://servicemix.apache.org/http/1.0"
>> >        xmlns:test="test.wsdl">
>> >
>> >   <http:endpoint service="test:TestService"
>> >                  endpoint="TestPort"
>> >                  role="consumer"
>> >                  locationURI="http://0.0.0.0:8193/TestService/"
>> >                  defaultMep="http://www.w3.org/2004/08/wsdl/in-out"
>> >                  soap="true"/>
>> >
>> > </beans>
>> >
>> > I send this message to the TestService :
>> >
>> > <?xml version="1.0" encoding="UTF-8"?>
>> > <soapenv:Envelope
>> > xsi:schemaLocation="http://schemas.xmlsoap.org/soap/envelope/
>> > http://schemas.xmlsoap.org/soap/envelope/"
>> > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>> > xmlns:xsd="http://www.w3.org/2001/XMLSchema"
>> > xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
>> > xmlns:sam="http://samples.aware.org/EchoSchema">
>> >   <soapenv:Body>
>> >    <echo xmlns="test.wsdl">
>> >     <sam:echo>
>> >       <s>test message</s>
>> >     </sam:echo>
>> >    </echo>
>> >   </soapenv:Body>
>> > </soapenv:Envelope>
>> >
>> > and I got the aforementioned error.
>> > If I send a similar message directly to the EchoService it works fine
>> > (obviously without the <echo xmlns="test.wsdl"> tag).
>> > So to summarize :
>> >
>> > soap client <---soap message------> EchoService-HTTP + SOAP <-------->
>> > EchoService-JSR181 : works.
>> >
>> > soap client <---soap message------> TestService-HTTP + SOAP <-------->
>> > TestService-ODE <--------> EchoService-HTTP + SOAP <-------->
>> > EchoService-JSR181 : fails.
>> >
>> >
>> >> What kind of message is it?   The
>> >> error message means that Ode can't recognize the message format, so it
>> >> can't
>> >> apply a message "mapper"  to convert non-JBI-normalized messages to
>> >> something Ode can understand.
>> >
>> > I suppose that the message format is soap, but maybe I'm wrong.
>> > Is there a way to verify this ?
>> > What Ode can understand ? How can I convert a message for it ?
>> >
>> > Cheers,
>> > Claudio
>> >
>> >>
>> >> cheers,
>> >> alex
>> >>
>> >>
>> >> On 1/17/07, claudio cacciari <c.cacciari@cineca.it> wrote:
>> >>>
>> >>> Hi All,
>> >>>
>> >>> I have tried to deploy and invoke a BPEL process with ODE inside
>> >>> servicemix.
>> >>> But I've got this error :
>> >>>
>> >>> ERROR - OdeService                     - Could not find a mapper for
>> >>> request message for JBI MEX
>> >>> ID:dhcp167-v71.pdl.cineca.it-51361-1169045820157-4:0; ODE MEX
>> >>> -8tfsk9ranl3s4o2mtfh9w0 is failed.
>> >>> ERROR - OdeService                     - Error invoking ODE.
>> >>> org.apache.ode.jbi.msgmap.MessageTranslationException: Could not find
>> a
>> >>> mapper for request message for JBI MEX
>> >>> ID:dhcp167-v71.pdl.cineca.it-51361-1169045820157-4:0; ODE MEX
>> >>> -8tfsk9ranl3s4o2mtfh9w0 is failed.
>> >>>         at org.apache.ode.jbi.OdeService.invokeOde(OdeService.java
>> :223)
>> >>>         at
>> >>> org.apache.ode.jbi.OdeService.onJbiMessageExchange(OdeService.java
>> :140)
>> >>>         at
>> >>>
>> org.apache.ode.jbi.JbiMessageExchangeEventRouter.onJbiMessageExchange(
>> >>> JbiMessageExchangeEventRouter.java:47)
>> >>>         at org.apache.ode.jbi.Receiver$1.run(Receiver.java:190)
>> >>>         at
>> >>> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java
>> :417)
>> >>>         at
>> >>> java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:269)
>> >>>         at java.util.concurrent.FutureTask.run(FutureTask.java:123)
>> >>>         at
>> >>> java.util.concurrent.ThreadPoolExecutor$Worker.runTask(
>> >>> ThreadPoolExecutor.java:650)
>> >>>         at
>> >>> java.util.concurrent.ThreadPoolExecutor$Worker.run(
>> ThreadPoolExecutor.java
>> >>>
>> >>> :675)
>> >>>         at java.lang.Thread.run(Thread.java:595)
>> >>>
>> >>> I'm using apache-servicemix-3.1-incubating-20070109.083014-50 and
>> >>> ode-jbi-2.0-SNAPSHOT .
>> >>> What this error means ?
>> >>>
>> >>> I put in attachment the wsdl and bpel descriptions of my process.
>> >>>
>> >>> Thank you for any feedback.
>> >>>
>> >>> Best Regards,
>> >>> Claudio
>> >
>> >
>>
>> --
>> View this message in context:
>> http://www.nabble.com/Error-invoking-jbi-ODE-inside-servicemix-tf3027855.html#a9106640
>> Sent from the Apache Ode User mailing list archive at Nabble.com.
>>
>>
> 
> 

-- 
View this message in context: http://www.nabble.com/Error-invoking-jbi-ODE-inside-servicemix-tf3027855.html#a9114768
Sent from the Apache Ode User mailing list archive at Nabble.com.


Mime
View raw message