ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "sujoy ray" <sujoy....@gmail.com>
Subject BPEL process deployment strange problem!!
Date Fri, 15 Dec 2006 03:28:36 GMT
Hi!! Everybody,

 First of all, Thanks to Matthieu and Alex for their spontaneous help.
I am a bit new in this area. I was developing a BPEL2.0 process with the
help of ode.
Now I am facing the following strange problem:

I wrote the WSDL and the BPEL process and deployed it in the Axis2 ode.
However, there
 is a strange change in the message as written by me and as exposed by the
service:

My WSDL message:

 <wsdl:message name="ProcessInputMessage">
     <wsdl:part name="xi1" type="xs:string"/>
          <wsdl:part name="xi2" type="xs:string"/>
          <wsdl:part name="xi3" type="xs:string"/>
          <wsdl:part name="xi4" type="xs:string"/>
          <wsdl:part name="weather1" type="xs:decimal"/>
          <wsdl:part name="weather2" type="xs:decimal"/>
          <wsdl:part name="weather3" type="xs:date"/>
          <wsdl:part name="weather4" type="xs:integer"/>
      <wsdl:part name="weather5" type="xs:string"/>
   </wsdl:message>

After deployment the service shows :

....
....

<xsd:element name="run">
<xsd:complexType>
<xsd:sequence>
  <xsd:element name="weather2" type="xs:decimal" />
  <xsd:element name="xi1" type="xs:string" />
  <xsd:element name="xi4" type="xs:string" />
  <xsd:element name="weather5" type="xs:string" />
  <xsd:element name="weather1" type="xs:decimal" />
  <xsd:element name="xi2" type="xs:string" />
  <xsd:element name="weather3" type="xs:date" />
  <xsd:element name="weather4" type="xs:integer" />
  <xsd:element name="xi3" type="xs:string" />
  </xsd:sequence>
  </xsd:complexType>
  </xsd:element>
<xsd:element name="runResponse">
<xsd:complexType>
<xsd:sequence>
  <xsd:element name="payload" type="xs:string" />
  </xsd:sequence>
  </xsd:complexType>
  </xsd:element>
  </xsd:schema>
  </wsdl:types>
<wsdl:message name="ProcessInputMessage">
  <wsdl:part name="part1" element="ns0:run" />
  </wsdl:message>
......



Is it common?? The problem is obvious only one partname is associated so I
cant differenciate the inputs and put them to the variable by the stub
generated from this wsdl. Moreover the sequence is changed also.

I tried parameterOrder= with the operation but its not fixing. I tried to
give input from client accordingly but theymake mess in the process.....

Can anybody please give me a quick solution to it? Am I doing something
wrong? For sure [:( ]

Regards,

Sujoy

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message