ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou" <matthieu.r...@gmail.com>
Subject Re: problem creating the deploy.xml for a process (urgent)
Date Mon, 06 Nov 2006 17:00:59 GMT
Looks like you're missing a WSDL document for your process or the WSDL
document isn't properly imported...

Matthieu

On 11/6/06, Alina Dima <dima.alina@gmail.com> wrote:
>
> Dear all,
>
> >
> > I am trying to create the Deployment file (attached) for a business
> > process (which is also attached). When I try to deploy it in Tomcat, I
> am
> > getting the following exception:
> >
> > WARN - BpelC.logCompilationMessage(420) |
> > file:///C:/Program%20Files/Apache%20So
> >
> >
> ftware%20Foundation/Tomcat%205.5/webapps/ode/WEB-INF/processes/BprId218/BpId318.
> > bpel:54: warning: [PARSER_WARNING] The "out" correlation pattern is the
> > only one that makes sense for <reply>.
> > ERROR - BpelC.logCompilationMessage(412) | error: [Bpel11RequiresWsdl] A
> > WSDL document must be specified for a BPEL4WS 1.1 process.
> > ERROR - DeploymentPoller.check(136) | Deployment of BprId218 failed,
> > aborting for now.
> > org.apache.ode.bpel.iapi.BpelEngineException: Compilation failure!
> >         at
> > org.apache.ode.bpel.deploy.DeploymentUnitImpl.loadProcessDefinitions(
> > DeploymentUnitImpl.java:148)
> >         at org.apache.ode.bpel.deploy.DeploymentUnitImpl.refresh
> > (DeploymentUnitI
> > mpl.java:288)
> >         at org.apache.ode.bpel.deploy.DeploymentUnitImpl
> > .<init>(DeploymentUnitIm
> > pl.java:110)
> >         at
> > org.apache.ode.bpel.deploy.DeploymentManagerImpl.createDeploymentUnit
> > (DeploymentManagerImpl.java:71)
> >         at org.apache.ode.bpel.engine.BpelServerImpl.deploy(
> > BpelServerImpl.java:
> > 630)
> >         at org.apache.ode.axis2.deploy.DeploymentPoller.check(
> > DeploymentPoller.j
> > ava:133)
> >         at org.apache.ode.axis2.deploy.DeploymentPoller.access$300
> > (DeploymentPol
> > ler.java:55)
> >         at
> org.apache.ode.axis2.deploy.DeploymentPoller$PollingThread.run
> > (Deploy
> > mentPoller.java:188)
> >
> > Could you please let me know what the problem with the way I write my
> > deploy.xml is? Also, is there any document which tells how exactly to
> > write this file?
> >
> > best,
> > Alina
> >
> >
> >
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message