ode-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthieu Riou" <matthieu.r...@gmail.com>
Subject Re: - SPAM - Re: Compiling errors
Date Thu, 19 Oct 2006 22:51:56 GMT
See http://incubator.apache.org/ode/getting-ode.html. The last 'testing'
section explains how to deploy the examples.

Cheers,

Matthieu

On 10/19/06, Vo, Khanh <kvo@systechnologies.com> wrote:
>
> It looks like the webpage for ODE has changed. There use to be some
> documentations on how to deploy examples.  I can't seem to get the
> helloworld2 to work anymore.  I think I am forgetting some step.
>
>
>
> Is it possible to get more documentation on how to use ODE?
>
>
>
> Thanks
>
> Khanh
>
>
>
> ________________________________
>
> From: Alex Boisvert [mailto:boisvert@intalio.com]
> Sent: Thursday, October 19, 2006 12:05 PM
> To: Vo, Khanh
> Cc: ode-user@incubator.apache.org
> Subject: Re: - SPAM - Re: Compiling errors
>
>
>
>
> Sorry, I haven't used Oracle's BPEL editor with Ode.
>
> alex
>
>
> Vo, Khanh wrote:
>
> I was doing a 'mvn ' .
>
> Looks like 'mvn install' is working.  By the way, have you use Oracle's
> Bpel editor and does it work with ODE well?
>
> Thanks.
> Khanh
>
> ________________________________
>
> From: Alex Boisvert [mailto:boisvert@intalio.com]
> Sent: Thu 10/19/2006 11:08 AM
> To: ode-user@incubator.apache.org
> Cc: Vo, Khanh
> Subject: - SPAM - Re: Compiling errors
>
>
>
>
> Did you do a 'mvn install' at the root?
>
>
> Vo, Khanh wrote:
>
>
>         Hello,
>
>         I had ODE compiling and running about a week ago.  After doing
> an update in subversion, I can nolonger compile ODE,  Can some help me
> with this problem?
>
>         Thanks
>         Khanh
>
>
>
>         [DEBUG] Trying repository apache-incubator
>         Downloading:
> http://people.apache.org/repo/m2-incubating-repository/org/apache/o
>         de/ode-jbi/2.0-SNAPSHOT/ode-jbi-2.0-SNAPSHOT-installer.zip
>         [WARNING] Unable to get resource from repository
> apache-incubator (http://people <http://people/> <http://people/>
>         .apache.org/repo/m2-incubating-repository)
>         [DEBUG] Trying repository central
>         Downloading:
> http://repo1.maven.org/maven2/org/apache/ode/ode-jbi/2.0-SNAPSHOT/o
>         de-jbi-2.0-SNAPSHOT-installer.zip
>         [WARNING] Unable to get resource from repository central
> (http://repo1.maven.org <http://repo1.maven.org/>
> <http://repo1.maven.org/>
>         /maven2)
>         [DEBUG] Unable to download the artifact from any repository
>         Try downloading the file manually from the project website.
>         Then, install it using the command:
>             mvn install:install-file -DgroupId=org.apache.ode
> -DartifactId=ode-jbi \
>                 -Dversion=2.0-SNAPSHOT -Dpackaging=zip
> -Dfile=/path/to/file
>         Path to dependency:
>                 1) org.apache.ode:distro-jbi:pom:2.0-SNAPSHOT
>                 2) org.apache.ode:ode-jbi:zip:installer:2.0-SNAPSHOT
>
>           org.apache.ode:ode-jbi:zip:2.0-SNAPSHOT
>         from the specified remote repositories:
>           central (http://repo1.maven.org/maven2),
>           intalio (http://pxe.intalio.org/public/maven2),
>           apache-incubator
> (http://people.apache.org/repo/m2-incubating-repository)
>         [INFO]
> ------------------------------------------------------------------------
>         [ERROR] BUILD ERROR
>         [INFO]
> ------------------------------------------------------------------------
>         [INFO] Failed to resolve artifact.
>         Missing:
>         ----------
>         1) org.apache.ode:ode-jbi:zip:installer:2.0-SNAPSHOT
>           Try downloading the file manually from the project website.
>           Then, install it using the command:
>               mvn install:install-file -DgroupId=org.apache.ode
> -DartifactId=ode-jbi \
>                   -Dversion=2.0-SNAPSHOT -Dpackaging=zip
> -Dfile=/path/to/file
>           Path to dependency:
>                 1) org.apache.ode:distro-jbi:pom:2.0-SNAPSHOT
>                 2) org.apache.ode:ode-jbi:zip:installer:2.0-SNAPSHOT
>         ----------
>         1 required artifact is missing.
>         for artifact:
>           org.apache.ode:distro-jbi:pom:2.0-SNAPSHOT
>         from the specified remote repositories:
>           central (http://repo1.maven.org/maven2),
>           intalio (http://pxe.intalio.org/public/maven2),
>           apache-incubator
> (http://people.apache.org/repo/m2-incubating-repository)
>
>         [INFO]
> ------------------------------------------------------------------------
>         [DEBUG] Trace
>         org.apache.maven.lifecycle.LifecycleExecutionException: Missing:
>         ----------
>         1) org.apache.ode:ode-jbi:zip:installer:2.0-SNAPSHOT
>           Try downloading the file manually from the project website.
>           Then, install it using the command:
>               mvn install:install-file -DgroupId=org.apache.ode
> -DartifactId=ode-jbi \
>                   -Dversion=2.0-SNAPSHOT -Dpackaging=zip
> -Dfile=/path/to/file
>           Path to dependency:
>                 1) org.apache.ode:distro-jbi:pom:2.0-SNAPSHOT
>                 2) org.apache.ode:ode-jbi:zip:installer:2.0-SNAPSHOT
>         ----------
>         1 required artifact is missing.
>         for artifact:
>           org.apache.ode:distro-jbi:pom:2.0-SNAPSHOT
>         from the specified remote repositories:
>           central (http://repo1.maven.org/maven2),
>           intalio (http://pxe.intalio.org/public/maven2),
>           apache-incubator
> (http://people.apache.org/repo/m2-incubating-repository)
>                 at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(Defa
>         ultLifecycleExecutor.java:551)
>                 at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLi
>         fecycle(DefaultLifecycleExecutor.java:475)
>                 at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(Defau
>         ltLifecycleExecutor.java:454)
>                 at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHan
>         dleFailures(DefaultLifecycleExecutor.java:306)
>                 at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegmen
>         ts(DefaultLifecycleExecutor.java:273)
>                 at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLi
>         fecycleExecutor.java:140)
>                 at
> org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:322)
>                 at
> org.apache.maven.DefaultMaven.execute(DefaultMaven.java:115)
>                 at org.apache.maven.cli.MavenCli.main(MavenCli.java:256)
>                 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
> Method)
>                 at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
>         java:39)
>                 at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
>         sorImpl.java:25)
>                 at java.lang.reflect.Method.invoke(Method.java:585)
>                 at
> org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
>                 at
> org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>                 at
> org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
>                 at
> org.codehaus.classworlds.Launcher.main(Launcher.java:375)
>         Caused by:
> org.apache.maven.artifact.resolver.MultipleArtifactsNotFoundException
>         : Missing:
>         ----------
>         1) org.apache.ode:ode-jbi:zip:installer:2.0-SNAPSHOT
>           Try downloading the file manually from the project website.
>           Then, install it using the command:
>               mvn install:install-file -DgroupId=org.apache.ode
> -DartifactId=ode-jbi \
>                   -Dversion=2.0-SNAPSHOT -Dpackaging=zip
> -Dfile=/path/to/file
>           Path to dependency:
>                 1) org.apache.ode:distro-jbi:pom:2.0-SNAPSHOT
>                 2) org.apache.ode:ode-jbi:zip:installer:2.0-SNAPSHOT
>         ----------
>         1 required artifact is missing.
>         for artifact:
>           org.apache.ode:distro-jbi:pom:2.0-SNAPSHOT
>         from the specified remote repositories:
>           central (http://repo1.maven.org/maven2),
>           intalio (http://pxe.intalio.org/public/maven2),
>           apache-incubator
> (http://people.apache.org/repo/m2-incubating-repository)
>                 at
> org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolveTra
>         nsitively(DefaultArtifactResolver.java:244)
>                 at
> org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolveTra
>         nsitively(DefaultArtifactResolver.java:211)
>                 at
> org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolveTra
>         nsitively(DefaultArtifactResolver.java:182)
>                 at
> org.apache.maven.plugin.DefaultPluginManager.resolveTransitiveDepende
>         ncies(DefaultPluginManager.java:1117)
>                 at
> org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPlugi
>         nManager.java:366)
>                 at
> org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(Defa
>         ultLifecycleExecutor.java:534)
>                 ... 16 more
>         [INFO]
> ------------------------------------------------------------------------
>         [INFO] Total time: 1 minute 47 seconds
>         [INFO] Finished at: Thu Oct 19 10:43:37 PDT 2006
>         [INFO] Final Memory: 23M/41M
>         [INFO]
> ------------------------------------------------------------------------
>         C:\work\ode\trunk>ode
>
>
>
>
>
>
>
>
>
>
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message