mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrei Sekretenko <asekrete...@mesosphere.io>
Subject Re: Review Request 71861: Moved creating authz Object out of `Master::authorizeResizeVolume`.
Date Thu, 02 Jan 2020 20:16:04 GMT


> On Dec. 4, 2019, 7:41 p.m., Benjamin Mahler wrote:
> > src/master/authorization.cpp
> > Lines 98-100 (patched)
> > <https://reviews.apache.org/r/71861/diff/2/?file=2181937#file2181937line98>
> >
> >     everything after "since" is only really relevant to RESERVE or UNRESERVE (pushing
or popping)
> >     
> >     I think this function should probably be renamed to `getLegacyValue(...)` and
the explanation of what the legacy `value` field is set to for a resource, and why.

Thanks; rewrote that old comment, hopefully now it can help reader understand why this function
does what it does. 

I don't think that `getLegacyValue(...)` is a proper name, as for some other operations the
legacy `value` is obtained by completely different means.

Left it as `static getReservationRole()`, but might be worth renaming into something like
`getEffectiveReservationRole()`/`getLegacyReservationRole()`/...


- Andrei


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/71861/#review218920
-----------------------------------------------------------


On Jan. 2, 2020, 8:01 p.m., Andrei Sekretenko wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/71861/
> -----------------------------------------------------------
> 
> (Updated Jan. 2, 2020, 8:01 p.m.)
> 
> 
> Review request for mesos, Benjamin Bannier and Benjamin Mahler.
> 
> 
> Bugs: MESOS-10023 and MESOS-10056
>     https://issues.apache.org/jira/browse/MESOS-10023
>     https://issues.apache.org/jira/browse/MESOS-10056
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Moved creating authz Object out of `Master::authorizeResizeVolume`.
> 
> 
> Diffs
> -----
> 
>   src/master/authorization.hpp PRE-CREATION 
>   src/master/authorization.cpp PRE-CREATION 
>   src/master/http.cpp 72587bf054e413402ebf4c6ff8060f7ca8ffcf1b 
>   src/master/master.hpp f97b085ae908278731acd326df68f9f381f09483 
>   src/master/master.cpp 14b90a5e276df055bb8a570331f27cab200c9869 
> 
> 
> Diff: https://reviews.apache.org/r/71861/diff/3/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Andrei Sekretenko
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message