mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benjamin Mahler <bmah...@apache.org>
Subject Re: Review Request 70320: Used `ResourceQuantities` in `__allocate()` when possible.
Date Wed, 27 Mar 2019 14:41:29 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/70320/#review214106
-----------------------------------------------------------



Looks good, just noticed another headroom variable that seems to warrant `ResourceQuantities`.
Also made a suggestion to avoid the createQuantitiesMap helper.

I saw the suggestion of posting benchmark results in subsequent patches, when are those patches
going to get posted with the results? If not so soon, then we may just want to post the benchmark
results in this patch so that we can ship it on its own sooner?


src/master/allocator/mesos/hierarchical.cpp
Line 1714 (original), 1713 (patched)
<https://reviews.apache.org/r/70320/#comment300278>

    s/Let sorter/Update sorter to/



src/master/allocator/mesos/hierarchical.cpp
Lines 1758 (patched)
<https://reviews.apache.org/r/70320/#comment300279>

    s/Let sorter/Update sorter to/



src/master/allocator/mesos/hierarchical.cpp
Lines 1765 (patched)
<https://reviews.apache.org/r/70320/#comment300280>

    s/Let sorter/Update sorter to/



src/master/allocator/mesos/hierarchical.cpp
Lines 1928 (patched)
<https://reviews.apache.org/r/70320/#comment300281>

    Rather than adding this additional function, can't `shrinkResoures` take a `ResourceQuantities`?



src/master/allocator/mesos/hierarchical.cpp
Lines 1956-1957 (original), 1949-1950 (patched)
<https://reviews.apache.org/r/70320/#comment300284>

    Clearer name, thanks!



src/master/allocator/mesos/hierarchical.cpp
Line 1962 (original), 1952 (patched)
<https://reviews.apache.org/r/70320/#comment300282>

    in the headroom surplus,



src/master/allocator/mesos/hierarchical.cpp
Lines 1961 (patched)
<https://reviews.apache.org/r/70320/#comment300283>

    Ditto here for just passing `ResourceQuantities`



src/master/allocator/mesos/hierarchical.cpp
Lines 2088-2091 (original), 2079-2082 (patched)
<https://reviews.apache.org/r/70320/#comment300285>

    This looks like a `ResourceQuantities`?


- Benjamin Mahler


On March 27, 2019, 5:31 a.m., Meng Zhu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/70320/
> -----------------------------------------------------------
> 
> (Updated March 27, 2019, 5:31 a.m.)
> 
> 
> Review request for mesos and Benjamin Mahler.
> 
> 
> Bugs: MESOS-9504
>     https://issues.apache.org/jira/browse/MESOS-9504
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Replaced `Resources` with `ResourceQuantities` when possible
> in `__allocate()`. This simplifies the code and improves
> performance.
> 
> 
> Diffs
> -----
> 
>   src/master/allocator/mesos/hierarchical.hpp 36bf90baf413e99c1580d516dfac0f074335d322

>   src/master/allocator/mesos/hierarchical.cpp 8bc749903b8ceb09a02e260919377483479302b5

> 
> 
> Diff: https://reviews.apache.org/r/70320/diff/1/
> 
> 
> Testing
> -------
> 
> make check
> Benchmark results coming in subsequent patches.
> 
> 
> Thanks,
> 
> Meng Zhu
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message