mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chun-Hung Hsiao <chhs...@apache.org>
Subject Re: Review Request 69161: Renamed a function argument to not reuse member name.
Date Fri, 02 Nov 2018 23:35:48 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/69161/#review210301
-----------------------------------------------------------


Fix it, then Ship it!




Thanks for cleaning this up!


src/resource_provider/storage/provider.cpp
Line 3065 (original), 3065 (patched)
<https://reviews.apache.org/r/69161/#comment294958>

    Maybe `operationInfo`, or just `operation`?
    Also if we go with this naming it would be nice to rename it in the declaration as well.


- Chun-Hung Hsiao


On Oct. 25, 2018, 10:54 a.m., Benjamin Bannier wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/69161/
> -----------------------------------------------------------
> 
> (Updated Oct. 25, 2018, 10:54 a.m.)
> 
> 
> Review request for mesos and Chun-Hung Hsiao.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> While a function argument shadowing a member variable is perfectly
> legal, it is still confusing. In this patch we rename the function
> argument to remove one case of such shadowing.
> 
> 
> Diffs
> -----
> 
>   src/resource_provider/storage/provider.cpp db783b53558811081fb2671e005e8bbbd9edbede

> 
> 
> Diff: https://reviews.apache.org/r/69161/diff/2/
> 
> 
> Testing
> -------
> 
> `make check`
> 
> 
> Thanks,
> 
> Benjamin Bannier
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message