mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benjamin Bannier <benjamin.bann...@mesosphere.io>
Subject Re: Review Request 68535: Updated Python dependencies for 3.7.
Date Tue, 28 Aug 2018 14:56:21 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/68535/#review208041
-----------------------------------------------------------




support/pip-requirements.txt
Line 2 (original), 2 (patched)
<https://reviews.apache.org/r/68535/#comment291786>

    This does not work for me when using a python2 setup,
    
        $ ./support/apply-reviews.py -r 68535 -c -n
        Congratulations! You have Python 3 installed correctly.
        Please start using the scripts in `support/python3`.
        Please also set the environment variable `MESOS_SUPPORT_PYTHON` to `3`
        so that the Git hooks use the Python 3 scripts.
        2018-08-28 16:52:32 URL:https://reviews.apache.org/r/68535/diff/raw/ [2156/2156] ->
"68535.patch" [1]
        The "pip-requirements.txt" file has changed.
        Rebuilding virtualenv...
          Could not find a version that satisfies the requirement pylint==2.1.1 (from -r /Users/bbannier/src/mesos/support/pip-requirements.txt
(line 2)) (from versions: 0.15.2, 0.16.0, 0.18.0, 0.18.1, 0.19.0, 0.20.0, 0.21.0, 0.21.1,
0.21.2, 0.21.3, 0.22.0, 0.23.0, 0.24.0, 0.25.0, 0.25.1, 0.25.2, 0.26.0, 0.27.0, 0.28.0, 1.0.0,
1.1.0, 1.2.0, 1.2.1, 1.3.0, 1.3.1, 1.4.0, 1.4.1, 1.4.2, 1.4.3, 1.4.4, 1.4.5, 1.5.0, 1.5.1,
1.5.2, 1.5.3, 1.5.4, 1.5.5, 1.5.6, 1.6.0, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.7.0, 1.7.1,
1.7.2, 1.7.3, 1.7.4, 1.7.5, 1.7.6, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.9.0, 1.9.1, 1.9.2,
1.9.3)
        No matching distribution found for pylint==2.1.1 (from -r /Users/bbannier/src/mesos/support/pip-requirements.txt
(line 2))
        New python executable in /Users/bbannier/src/mesos/support/.virtualenv/bin/python2.7
        Also creating executable in /Users/bbannier/src/mesos/support/.virtualenv/bin/python
        Installing setuptools, pip, wheel...done.
        Running virtualenv with interpreter /usr/local/opt/python@2/bin/python
        Requirement already up-to-date: pip in ./support/.virtualenv/lib/python2.7/site-packages
(18.0)
        Collecting nodeenv==1.3.2 (from -r /Users/bbannier/src/mesos/support/pip-requirements.txt
(line 1))
          Using cached https://files.pythonhosted.org/packages/36/ca/1a635c6cd6049105fadfdc05c8de364f368fcc7aebad3081dd8ccb0c5c7f/nodeenv-1.3.2.tar.gz
        Collecting pylint==2.1.1 (from -r /Users/bbannier/src/mesos/support/pip-requirements.txt
(line 2))
        
    Let's either pin a version which works for both python2.7 and >=python3.6, or introduce
a dedicated virtualenv for the files in `support/python3`.


- Benjamin Bannier


On Aug. 28, 2018, 10:05 a.m., Armand Grillet wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/68535/
> -----------------------------------------------------------
> 
> (Updated Aug. 28, 2018, 10:05 a.m.)
> 
> 
> Review request for mesos, Benjamin Bannier and Robin Gögge.
> 
> 
> Bugs: MESOS-9186
>     https://issues.apache.org/jira/browse/MESOS-9186
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> All the dependencies are now fixed so that we will only need to update
> when a new Python version is being released.
> 
> 
> Diffs
> -----
> 
>   src/python/cli_new/pip-requirements.txt 8645912a63b22878f477e96bfa8bc95abe893f85 
>   src/python/cli_new/tox.ini a9a2e69156484a4d172a2746f8cc51089445ae17 
>   src/python/lib/tox.ini 0779fb22d1e8af2dbd17d0fb6b1c8cf3dc2e37d3 
>   support/pip-requirements.txt 89c2de287bc26bbde3006b587a4a8c1bae6f600b 
> 
> 
> Diff: https://reviews.apache.org/r/68535/diff/1/
> 
> 
> Testing
> -------
> 
> Used the scripts and saw that the error describe in MESOS-9186 is gone. Multiple packages
had issues with Python 3.7 and I have used versions that include fixes for those.
> 
> 
> Thanks,
> 
> Armand Grillet
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message