mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chun-Hung Hsiao <chhs...@apache.org>
Subject Review Request 67156: Renamed `grpc::Channel` to `grpc::client::Connection`.
Date Wed, 16 May 2018 19:25:24 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/67156/
-----------------------------------------------------------

Review request for mesos, Benjamin Bannier, Benjamin Mahler, Jie Yu, and Zhitao Li.


Bugs: MESOS-8924
    https://issues.apache.org/jira/browse/MESOS-8924


Repository: mesos


Description
-------

This renaming is made to avoid name conflicts between `::grpc::Channel`
and libprocess' own wrapper. Also, since this wrapper is only used
at the client side, it is moved into the `client` namespace.

NOTE: The name `client::Connection` matches the `ClientConn` function
in gRPC Go API, so it should be a good name for `::grpc::Channel`.


Diffs
-----

  3rdparty/libprocess/include/process/grpc.hpp 321a46e19c69eafb24012bcef68bb8b0cc6aa436 
  3rdparty/libprocess/src/tests/grpc_tests.cpp 38cd6c61b54518a1019bb11a3551be13026c3f0d 


Diff: https://reviews.apache.org/r/67156/diff/1/


Testing
-------

make check in libprocess

NOTE: Mesos cannot be built with this patch standalone. The tests are done later in the chain.


Thanks,

Chun-Hung Hsiao


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message