mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Mann <g...@mesosphere.io>
Subject Re: Review Request 66823: Added per framework metrics for framework events.
Date Tue, 15 May 2018 21:58:29 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/66823/#review203166
-----------------------------------------------------------




src/master/master.hpp
Lines 2381 (patched)
<https://reviews.apache.org/r/66823/#comment285249>

    I'm curious what the performance impact of this will be during a period of high event
throughput. Do you think it's worth adding the new helper for message -> event conversion
now?



src/master/metrics.hpp
Lines 240 (patched)
<https://reviews.apache.org/r/66823/#comment285259>

    I think another name might be more intuitive for this variable - maybe `event_update_types`
or `task_status_update_types` or similar?



src/master/metrics.cpp
Lines 612 (patched)
<https://reviews.apache.org/r/66823/#comment285260>

    Do we need this temporary variable? Here and below.


- Greg Mann


On May 11, 2018, 8:44 a.m., Gilbert Song wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/66823/
> -----------------------------------------------------------
> 
> (Updated May 11, 2018, 8:44 a.m.)
> 
> 
> Review request for mesos, Benjamin Mahler, Gaston Kleiman, Greg Mann, Jie Yu, and Vinod
Kone.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added per framework metrics for framework events.
> 
> 
> Diffs
> -----
> 
>   src/master/master.hpp 5ec764b5c7f96bab786084cccf20fd8a17319718 
>   src/master/metrics.hpp ec76dbcd1d1fa5349d62ce73fb9603e1986a776b 
>   src/master/metrics.cpp e46ead79f3f29e285426f9d061337077f453aa45 
> 
> 
> Diff: https://reviews.apache.org/r/66823/diff/5/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Gilbert Song
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message