mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chun-Hung Hsiao <chhs...@apache.org>
Subject Re: Review Request 66996: Removed the OpenSSL dependency for building gRPC in Mesos.
Date Wed, 09 May 2018 00:37:51 GMT


> On May 8, 2018, 9:33 a.m., Benjamin Bannier wrote:
> > src/Makefile.am
> > Line 182 (original), 185 (patched)
> > <https://reviews.apache.org/r/66996/diff/1/?file=2017787#file2017787line186>
> >
> >     It is not clear to me that this would always find the correct libraries. I see
e.g., that the cmake build does not seem to use the `_unsecure` suffix even when the libraries
where built without SSL.
> >     
> >     Do we need to explicitly discover these libraries during configure time to make
sure we don't risk failing to link later?
> 
> Chun-Hung Hsiao wrote:
>     We already did: https://github.com/apache/mesos/blob/master/configure.ac#L2072. The
assumption here is that for custom grpc, we assume the whole grpc package is installed so
the standard grpc library must be there.
> 
> Chun-Hung Hsiao wrote:
>     I'll just use the standard libs here as well.

Hmm. Actually, let me check the "unsecure" variant in `configure.ac` instead.


- Chun-Hung


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/66996/#review202621
-----------------------------------------------------------


On May 8, 2018, 3:23 a.m., Chun-Hung Hsiao wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/66996/
> -----------------------------------------------------------
> 
> (Updated May 8, 2018, 3:23 a.m.)
> 
> 
> Review request for mesos, Benjamin Bannier, Gaston Kleiman, and Jie Yu.
> 
> 
> Bugs: MESOS-8798
>     https://issues.apache.org/jira/browse/MESOS-8798
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> When the SSL build feature is disabled, Mesos now builds
> `libgrpc_unsecure` and `libgrpc++_unsecure` instead of `libgrpc` and
> `libgrpc++`, so the SSL headers and libraries are no longer required.
> 
> NOTE: gRPC v1.10 no longer needs `-Wno-deprecated-declarations` and
> `-Wno-unused-function` when building with OpenSSL v1.1.
> 
> 
> Diffs
> -----
> 
>   3rdparty/Makefile.am 8d9fa85dd65a94d91670d54dab36deea80d14996 
>   configure.ac 429797c35b93a6df69ba0cb0fc28cb66a3171074 
>   src/Makefile.am 7e91681e3b8b217f8b23fa5347e059640c62fc65 
>   src/python/native_common/ext_modules.py.in 87387fd580c40b252fc82f98b5238b9b9120903a

> 
> 
> Diff: https://reviews.apache.org/r/66996/diff/1/
> 
> 
> Testing
> -------
> 
> This patch does not work standalone. Tests are done in the next patch.
> 
> 
> Thanks,
> 
> Chun-Hung Hsiao
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message