mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gaston Kleiman <gas...@mesosphere.io>
Subject Re: Review Request 63994: Added a new test for validation of offer operation IDs.
Date Fri, 02 Mar 2018 22:46:11 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/63994/#review198559
-----------------------------------------------------------




src/tests/scheduler_tests.cpp
Lines 1045-1047 (patched)
<https://reviews.apache.org/r/63994/#comment278756>

    These and lines 1056, 1069-1078 can be replaced with:
    
    ```
      EXPECT_CALL(*scheduler, connected(_))
       .WillOnce(v1::scheduler::SendSubscribe(v1::DEFAULT_FRAMEWORK_INFO))
    ```



src/tests/scheduler_tests.cpp
Lines 1096-1142 (patched)
<https://reviews.apache.org/r/63994/#comment278757>

    Can we make this shorter and more readble using the following helpers?
    
    `v1::createTask`, `v1::createTaskGroupInfo`, `v1::LAUNCH`, `v1::LAUNCH_GROUP`, `v1::createCallAccept`,
see `default_executor_tests.cpp` for multiple usage examples.



src/tests/scheduler_tests.cpp
Lines 1154-1155 (patched)
<https://reviews.apache.org/r/63994/#comment278758>

    We can use this again:
    
    ```
      EXPECT_CALL(*scheduler, connected(_))
       .WillOnce(v1::scheduler::SendSubscribe(v1::DEFAULT_FRAMEWORK_INFO))
    ```



src/tests/scheduler_tests.cpp
Lines 1197-1227 (patched)
<https://reviews.apache.org/r/63994/#comment278761>

    Do we really need this complicated logic?
    
    Wouldn't it be easier to terminate the original agent and create a new one from scratch
without the `RESOURCE_PROVIDER` capability?



src/tests/scheduler_tests.cpp
Lines 1247-1264 (patched)
<https://reviews.apache.org/r/63994/#comment278760>

    I think that using the helpers here would also improve readability.


- Gaston Kleiman


On March 2, 2018, 12:07 a.m., Greg Mann wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/63994/
> -----------------------------------------------------------
> 
> (Updated March 2, 2018, 12:07 a.m.)
> 
> 
> Review request for mesos, Benjamin Bannier, Gaston Kleiman, and Jie Yu.
> 
> 
> Bugs: MESOS-8190
>     https://issues.apache.org/jira/browse/MESOS-8190
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> This patch adds a new test,
> 'SchedulerTest.OfferOperationFeedbackValidation',
> to verify that task and offer operation status updates are correctly
> sent when the 'id' field is set incorrectly on an operation.
> 
> 
> Diffs
> -----
> 
>   src/tests/scheduler_tests.cpp 397a0908432ad50fa94fd939a604b096a06f8a1d 
> 
> 
> Diff: https://reviews.apache.org/r/63994/diff/2/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Greg Mann
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message