mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Akash Gupta <akash-gu...@hotmail.com>
Subject Re: Review Request 64386: Refactored health checks to take in executor information.
Date Mon, 29 Jan 2018 18:40:10 GMT


> On Jan. 22, 2018, 1:27 p.m., Alexander Rukletsov wrote:
> > src/checks/checker_process.hpp
> > Lines 40-47 (patched)
> > <https://reviews.apache.org/r/64386/diff/8/?file=1941023#file1941023line40>
> >
> >     What meaning do you put in the difference between `UCR` and `MESOS`? For me,
the difference is whether the checker library talks to the task directly or via a container
runtime; as a consequence, different types of command checks is used.
> 
> Joseph Wu wrote:
>     The `UCR` and `MESOS` enums should be combined for now, as there is no logical difference
between them at the moment.  (You could actually use nested container health checks on "`MESOS`"
executors, if you had the necessary credentials.)
> 
> Alexander Rukletsov wrote:
>     We can, but I'd like to split them up exactly for this reason: to make clear for
the library user which type of command health check is used (nested or plain).

It might be better to rename `UCR` to `MESOS_NESTED` since the name is closer to what's actually
happening in the health check.


> On Jan. 22, 2018, 1:27 p.m., Alexander Rukletsov wrote:
> > src/launcher/default_executor.cpp
> > Lines 551 (patched)
> > <https://reviews.apache.org/r/64386/diff/8/?file=1941029#file1941029line551>
> >
> >     I'd argue, you should use `UCR` here: the library relies on the agent (which
contains UCR) for command health checks.

Yeah, that makes sense to me.


> On Jan. 22, 2018, 1:27 p.m., Alexander Rukletsov wrote:
> > src/launcher/executor.cpp
> > Lines 653-658 (patched)
> > <https://reviews.apache.org/r/64386/diff/8/?file=1941030#file1941030line653>
> >
> >     How is this used in the checker library at the moment? Do you distinguish there
between Mesos and UCR?

I think I'm getting confused on what `UCR` actually means. I think maybe it's better to change
`UCR` to `MESOS_NESTED` and from that it's easy to see that this should have just been `MESOS`
instead of the conditional.


- Akash


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/64386/#review195894
-----------------------------------------------------------


On Jan. 17, 2018, 12:10 p.m., Akash Gupta wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/64386/
> -----------------------------------------------------------
> 
> (Updated Jan. 17, 2018, 12:10 p.m.)
> 
> 
> Review request for mesos, Alexander Rukletsov, Andrew Schwartzmeyer, Gaston Kleiman,
Jie Yu, Joseph Wu, and Michael Park.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added information about the calling executor to the health check
> library. After the refactoring, the command health check code originally
> in the docker executor is now in the health check library.
> 
> 
> Diffs
> -----
> 
>   src/checks/checker.hpp 93502270f31e80c5f7c94b5b456625e9cdea1837 
>   src/checks/checker.cpp fff0aac504b4283a210f936e00c977fa60d88b3d 
>   src/checks/checker_process.hpp 510f3b2e6e689faaf26595214ce377c2b5518f28 
>   src/checks/checker_process.cpp ddb197b8cc2c503fef5ae20af32f5881fff9833f 
>   src/checks/health_checker.hpp 019fbd791f250ecc28ff59d779f90e7ccbf0c685 
>   src/checks/health_checker.cpp eaf9a18817eeeff7c29c7a4b9d1b183f398760a3 
>   src/docker/docker.hpp d9e71f8841a868082170d28fc4f3d495e2eb1e61 
>   src/docker/executor.cpp e4c53d558e414e50b1c429fba8e31e504c63744a 
>   src/launcher/default_executor.cpp 4a619859095cc2d30f4806813f64a2e48c83b3ea 
>   src/launcher/executor.cpp 050f5a057f360873e2b4738b126289bcd1bd0c7f 
> 
> 
> Diff: https://reviews.apache.org/r/64386/diff/8/
> 
> 
> Testing
> -------
> 
> See https://reviews.apache.org/r/64387/
> 
> 
> Thanks,
> 
> Akash Gupta
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message