mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jie Yu <yujie....@gmail.com>
Subject Re: Review Request 63001: Updated protobuf definitions related to offer operations.
Date Fri, 27 Oct 2017 21:04:40 GMT


> On Oct. 26, 2017, 10:49 p.m., Greg Mann wrote:
> > include/mesos/resource_provider/resource_provider.proto
> > Line 66 (original), 72 (patched)
> > <https://reviews.apache.org/r/63001/diff/9/?file=1863089#file1863089line72>
> >
> >     Do you want to use `OFFER_OPERATION` here instead? Or, do you think it's OK
to just use `OPERATION` since this is within the RP? Here and elsewhere.

Yeah, I'll use OFFER_OPERATION consistently.


> On Oct. 26, 2017, 10:49 p.m., Greg Mann wrote:
> > include/mesos/v1/mesos.proto
> > Lines 2145 (patched)
> > <https://reviews.apache.org/r/63001/diff/9/?file=1863090#file1863090line2145>
> >
> >     I'm a little bit concerned that the names of the various IDs in this RR will
become confusing for devs. We have:
> >     1) `OfferOperationID`, with a field name of `operation_id`
> >     2) `bytes uuid`, with a field name of `uuid` (this is the status update ID)
> >     3) `bytes uuid`, with a field name of `operation_uuid` (this is our internal
ID for the operation)
> >     
> >     What would you think about naming the fields `operation_id`, `operation_update_uuid`,
and `operation_internal_uuid`, respectively? (could also just do `update_uuid` and `internal_uuid`
for the latter two)
> >     
> >     Since the fields are in different messages, I'm not sure how bad this would
really be, just a thought. Let me know what you think.

In `Offer.Operation`, the field is `id`, which reads well because the context is clear. In
`OfferOperationStatus`, it's `operation_id`, which also makes sense to me because we might
have different `id` in that message.
In `OfferOperation`, it's `operation_uuid`. The reason for `operation_` prefix is because
there are `framework_id` in the message. Adding a prefix makes the context more clear (similar
to above). So each offer operation has a `id` (specified by the framework) and a `uuid` which
is generated by the master.

I agree with you that `uuid` in `OfferOperationStatus` is a bit confusing. How about renaming
it to `status_uuid`?


- Jie


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/63001/#review189354
-----------------------------------------------------------


On Oct. 27, 2017, 12:58 p.m., Jie Yu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/63001/
> -----------------------------------------------------------
> 
> (Updated Oct. 27, 2017, 12:58 p.m.)
> 
> 
> Review request for mesos, Benjamin Bannier, Benjamin Mahler, Gaston Kleiman, Greg Mann,
Jan Schlicht, and Vinod Kone.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Updated protobuf definitions related to offer operations.
> 
> 
> Diffs
> -----
> 
>   include/mesos/mesos.proto 859fdff4d9a0604bc506b08af79075084ae23466 
>   include/mesos/resource_provider/resource_provider.proto f5a9073075327019fd133bd51265f695ef464845

>   include/mesos/v1/mesos.proto cfd4abd3af1d8c9fbd31659161eada9ec9f92282 
>   include/mesos/v1/resource_provider/resource_provider.proto e5cbede5b6e57a8641fca1ebfee5454f292cc24c

>   src/messages/messages.proto 0a32b3457e9143a7d48670610ca3e56dd516136f 
>   src/resource_provider/manager.cpp 31fcb789f5ab907511e868c374c49f7457a33ed3 
>   src/resource_provider/validation.cpp d2927227f60ab0d4ae2481ad73a31ee444b48ee0 
>   src/tests/resource_provider_validation_tests.cpp f182bff4670318e9de22c2915c5dbb423a74ad6c

> 
> 
> Diff: https://reviews.apache.org/r/63001/diff/10/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Jie Yu
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message