mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vinod Kone <vinodk...@gmail.com>
Subject Re: Review Request 61029: Added metric for connected API subscribers in the master.
Date Tue, 25 Jul 2017 21:21:42 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/61029/#review181385
-----------------------------------------------------------




src/master/metrics.cpp
Lines 75 (patched)
<https://reviews.apache.org/r/61029/#comment256920>

    Different streaming api clients (schedulers, executors, operators) send requests to "/api/v1/some/path":
      -- /api/v1 on master for SUBSCRIBE
      -- /api/v1 on agent for LAUNCH_NESTED_CONTAINER_SESSION and ATTACH_CONTAINER_{INPUT,OUTPUT}
and 
      -- /api/v1/scheduler on master for SUBSCRIBE
      
    So calling just the clients to /api/v1 on master as "api_subscribers_connected" is confusing.
We need to come up with a naming scheme that works for all these different clients.


- Vinod Kone


On July 24, 2017, 1:34 p.m., Alexander Rukletsov wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/61029/
> -----------------------------------------------------------
> 
> (Updated July 24, 2017, 1:34 p.m.)
> 
> 
> Review request for mesos, Armand Grillet and Vinod Kone.
> 
> 
> Bugs: MESOS-7747
>     https://issues.apache.org/jira/browse/MESOS-7747
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> See summary.
> 
> 
> Diffs
> -----
> 
>   src/master/master.hpp 84465af782d4024f22463d981ef9d0ef7827d043 
>   src/master/master.cpp e12c997dad04f8a4ddb47a993a84b2b05c9e2f32 
>   src/master/metrics.hpp f701efec0a82d6ba72b2414f739fcd1cd7ee2491 
>   src/master/metrics.cpp 646041d53642d6c25c3ea735bd9c87784374084f 
>   src/tests/master_tests.cpp e3ccf8ce32d7314e6003798404a43b2f1e83a166 
> 
> 
> Diff: https://reviews.apache.org/r/61029/diff/1/
> 
> 
> Testing
> -------
> 
> See https://reviews.apache.org/r/61034/
> 
> 
> Thanks,
> 
> Alexander Rukletsov
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message