mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benjamin Mahler <bmah...@apache.org>
Subject Re: Review Request 60370: Updated agent webui page to display allocated resources per each role.
Date Tue, 18 Jul 2017 04:08:25 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/60370/#review180790
-----------------------------------------------------------


Fix it, then Ship it!





src/webui/master/static/agent.html
Lines 167 (patched)
<https://reviews.apache.org/r/60370/#comment256020>

    Just to be very clear can we s/Role/Reservation Role/ here? I've seen users be confused
about the distinction between allocation role and reservation role, and we'll be specifying
this distinction anyway in the more complete table [1](https://docs.google.com/spreadsheets/d/19I3gNn5SvRcQLp2Th5yHGvIfFLfZTM1PWkoEQDuuGG4/edit#gid=0).



src/webui/master/static/agent.html
Lines 179 (patched)
<https://reviews.apache.org/r/60370/#comment256023>

    It would clean up a lot of the UI html if we have a size-specific filter (i.e. `dataSizeMb`),
because all of these `1024*1024`s we're accumulating are detracting from readability of the
code and we sometimes forget to add them. Could you send a follow up patch to add `dataSizeMb`
and clean up the `1024*1024`s throughout the html pages?



src/webui/master/static/js/controllers.js
Lines 604 (patched)
<https://reviews.apache.org/r/60370/#comment256021>

    This is describing the "what", could we describe the "why"? E.g. we transform the map
into an array for inclusion in ng-repeat
    
    By the way, from what I can tell, we may not need to conver to an array (e.g. https://stackoverflow.com/a/15127934)
but it seems that the recommendation is to always convert to an array as you've done due to
some issues (I didn't dig in further, you might want to).



src/webui/master/static/js/controllers.js
Lines 605 (patched)
<https://reviews.apache.org/r/60370/#comment256022>

    How about `reserved_resources_as_array`? It starts to get really confusing if we have
variables like `reserved_resources` and `resource_reservations` since they're the same information
in map vs array form but the names don't suggest this?


- Benjamin Mahler


On June 28, 2017, 8:52 p.m., Andrei Budnik wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/60370/
> -----------------------------------------------------------
> 
> (Updated June 28, 2017, 8:52 p.m.)
> 
> 
> Review request for mesos, Benjamin Mahler and haosdent huang.
> 
> 
> Bugs: MESOS-6441
>     https://issues.apache.org/jira/browse/MESOS-6441
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Updated agent webui page to display allocated resources per each role.
> 
> 
> Diffs
> -----
> 
>   src/webui/master/static/agent.html 71e5e702e5e64e6f46c84791247aa5156c046ed9 
>   src/webui/master/static/js/controllers.js 67bfd030649dd21840c16188a4964f814aa232d7

> 
> 
> Diff: https://reviews.apache.org/r/60370/diff/6/
> 
> 
> Testing
> -------
> 
> See screenshot.
> 
> 
> File Attachments
> ----------------
> 
> agent.html
>   https://reviews.apache.org/media/uploaded/files/2017/06/22/66cc61b4-04c8-451e-a434-58f556397724__Resource_Reservations.png
> ui_bug
>   https://reviews.apache.org/media/uploaded/files/2017/06/28/1b7755e3-0b11-46ab-9ae4-71f19bce0cd6__ui_bug.png
> ui_bug2
>   https://reviews.apache.org/media/uploaded/files/2017/06/28/b89990c9-9aa5-432a-a0da-3f90c9428127__ui_bug2.png
> ui_bug3
>   https://reviews.apache.org/media/uploaded/files/2017/06/28/51553e9d-7fb9-40c0-b47c-b62fc6c37393__ui_bug3.png
> 
> 
> Thanks,
> 
> Andrei Budnik
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message