mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Peach <jpe...@apache.org>
Subject Re: Review Request 59554: Rename the `--allowed_capabilities` flag to `--effective_capabilities`.
Date Mon, 05 Jun 2017 16:57:42 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/59554/
-----------------------------------------------------------

(Updated June 5, 2017, 4:57 p.m.)


Review request for mesos, Jie Yu and Jiang Yan Xu.


Changes
-------

Rebased.


Bugs: MESOS-7477
    https://issues.apache.org/jira/browse/MESOS-7477


Repository: mesos


Description
-------

Since the `--allowed_capabilities` flag was being used to actually
grant capabilities, rename it to `--effective_capabilities` which better
conveys the intention and semantics of this flag.


Diffs (updated)
-----

  docs/configuration.md ed510fa638878b71e7fcff4850152a8a8622127e 
  docs/linux_capabilities.md b588aff6842a14bbf7ff5c35931cac61f9019805 
  src/slave/containerizer/mesos/isolators/linux/capabilities.cpp 60d22aa877c1ab62a08222e5efe8800e337684da

  src/slave/flags.hpp 2f9d52e94c2c31e95208cd8b0640a5de2d2a61fd 
  src/slave/flags.cpp 93c8ffb5c822cf6c99071be7aca52a6b3d187619 
  src/tests/containerizer/linux_capabilities_isolator_tests.cpp 40376a03fdb8f931f8d3f83b1c3fa6207e02c1d1



Diff: https://reviews.apache.org/r/59554/diff/2/

Changes: https://reviews.apache.org/r/59554/diff/1-2/


Testing
-------

make check (Fedora 25)


Thanks,

James Peach


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message