mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Rukletsov <ruklet...@gmail.com>
Subject Re: Review Request 58191: Renamed a test helper for clarity.
Date Wed, 19 Apr 2017 15:15:11 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/58191/
-----------------------------------------------------------

(Updated April 19, 2017, 3:15 p.m.)


Review request for mesos, Gastón Kleiman and Vinod Kone.


Changes
-------

Rebased. NNTR.


Repository: mesos


Description
-------

`HealthCheckTestHelper` is actually a simple libprocess-based HTTP
server. To make it clear and enable it usage in non health check
related tests, rename it to `HttpServerTestHelper`.


Diffs (updated)
-----

  src/Makefile.am 1fc453c497f278c9fc3fa5e91eb720a932915fde 
  src/tests/CMakeLists.txt 8e368a8c8f83293529e00f9902174bff8e798d51 
  src/tests/check_tests.cpp 79ba5eb38b6e7338392fb17ad39f6cd250f87d88 
  src/tests/health_check_test_helper.hpp cdedf09ebaeb976d33090fe708b0ce5c118a6682 
  src/tests/health_check_test_helper.cpp 88352c1bfe5d484ec2ba602b4f9a8139c868fef7 
  src/tests/health_check_tests.cpp 3bba1bb28ce8bde8abc14e3303264d6fdea64286 
  src/tests/test_helper_main.cpp 5d99ede44f958b36d33dede02f2ab7a5854a01f3 


Diff: https://reviews.apache.org/r/58191/diff/2/

Changes: https://reviews.apache.org/r/58191/diff/1-2/


Testing
-------

See https://reviews.apache.org/r/58196/


Thanks,

Alexander Rukletsov


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message