mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Rukletsov <ruklet...@gmail.com>
Subject Review Request 58191: Renamed a test helper for clarity.
Date Tue, 04 Apr 2017 22:23:34 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/58191/
-----------------------------------------------------------

Review request for mesos, Gastón Kleiman and Vinod Kone.


Repository: mesos


Description
-------

`HealthCheckTestHelper` is actually a simple libprocess-based HTTP
server. To make it clear and enable it usage in non health check
related tests, rename it to `HttpServerTestHelper`.


Diffs
-----

  src/Makefile.am 071656ad7354a802e8292140a7181cb70b68fe9e 
  src/tests/CMakeLists.txt 8e368a8c8f83293529e00f9902174bff8e798d51 
  src/tests/check_tests.cpp d7fcbf940102efe0841f07e8c4937a78361bc422 
  src/tests/health_check_test_helper.hpp cdedf09ebaeb976d33090fe708b0ce5c118a6682 
  src/tests/health_check_test_helper.cpp 88352c1bfe5d484ec2ba602b4f9a8139c868fef7 
  src/tests/health_check_tests.cpp 211f8b8578e811d3f2a229387cc0ce8327ae8cb6 
  src/tests/test_helper_main.cpp 5d99ede44f958b36d33dede02f2ab7a5854a01f3 


Diff: https://reviews.apache.org/r/58191/diff/1/


Testing
-------

See https://reviews.apache.org/r/58196/


Thanks,

Alexander Rukletsov


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message