mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From haosdent huang <haosd...@apache.org>
Subject Re: Review Request 55160: Added test for DockerContainerizer when `cgroups_enable_cfs` is set.
Date Mon, 06 Feb 2017 05:50:42 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/55160/#review164308
-----------------------------------------------------------




src/tests/containerizer/docker_containerizer_tests.cpp (line 39)
<https://reviews.apache.org/r/55160/#comment235995>

    Nit: Add an extra blank line here.



src/tests/containerizer/docker_containerizer_tests.cpp (line 40)
<https://reviews.apache.org/r/55160/#comment235996>

    Nit: Add an extra line here.
    
    ```
    #include "slave/containerizer/fetcher.hpp"
    
    #include "slave/containerizer/mesos/isolators/cgroups/constants.hpp"
    ```



src/tests/containerizer/docker_containerizer_tests.cpp (line 4083)
<https://reviews.apache.org/r/55160/#comment236000>

    the test filter `CGROUPS_CFS_` is required for this test case.



src/tests/containerizer/docker_containerizer_tests.cpp (line 4095)
<https://reviews.apache.org/r/55160/#comment236001>

    `"cpus:1;mem:128"` should be enough?



src/tests/containerizer/docker_containerizer_tests.cpp (lines 4193 - 4199)
<https://reviews.apache.org/r/55160/#comment236002>

    I think we could replace this with
    
    ```
    Try<Duration> cfsQuota = cgroups::cpu::cfs_quota_us(cpuHierarchy.get(), cpuCgroup.get());
    ```



src/tests/containerizer/docker_containerizer_tests.cpp (line 4201)
<https://reviews.apache.org/r/55160/#comment236003>

    should we use a better name, `expectedCpuQuota` and `cpuQuota`?



src/tests/containerizer/docker_containerizer_tests.cpp (lines 4211 - 4213)
<https://reviews.apache.org/r/55160/#comment236004>

    This seems uncessary.


- haosdent huang


On Feb. 5, 2017, 11:09 p.m., Zhitao Li wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/55160/
> -----------------------------------------------------------
> 
> (Updated Feb. 5, 2017, 11:09 p.m.)
> 
> 
> Review request for mesos, Gilbert Song, haosdent huang, and Jie Yu.
> 
> 
> Bugs: MESOS-6134
>     https://issues.apache.org/jira/browse/MESOS-6134
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added test for DockerContainerizer when `cgroups_enable_cfs` is set.
> 
> 
> Diffs
> -----
> 
>   src/tests/containerizer/docker_containerizer_tests.cpp 31d63b1f239055d82470ace9024b584a2096dce4

> 
> Diff: https://reviews.apache.org/r/55160/diff/
> 
> 
> Testing
> -------
> 
> Run the new test.
> 
> 
> Thanks,
> 
> Zhitao Li
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message