mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Rukletsov <ruklet...@gmail.com>
Subject Re: Review Request 55901: Added support for command health checks to the default executor.
Date Fri, 03 Feb 2017 13:34:51 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/55901/#review164117
-----------------------------------------------------------




src/checks/health_checker.hpp (line 94)
<https://reviews.apache.org/r/55901/#comment235698>

    Could you please add a todo here saying this will go away and link a jira ticket?



src/checks/health_checker.hpp (line 207)
<https://reviews.apache.org/r/55901/#comment235702>

    How about calling it `commandCheckViaAgent`?



src/checks/health_checker.cpp (line 130)
<https://reviews.apache.org/r/55901/#comment235700>

    s/createRequest/createV1AgentAPIRequest?
    remove `inline`
    
    This looks like a utility function not really related to the health checker library. Maybe
put it into "src/slave/api_utils.{hpp|cpp}"?



src/checks/health_checker.cpp (lines 146 - 170)
<https://reviews.apache.org/r/55901/#comment235701>

    What is the value of using these helpers? I'd say having `connection.send(createRequest(url,
call), false);` is clearer and self explanatory rather than `post(connection, url, call)`.
And you don't need any comments then : )



src/checks/health_checker.cpp (line 224)
<https://reviews.apache.org/r/55901/#comment235699>

    You can use `{}` instead.



src/checks/health_checker.cpp (lines 434 - 436)
<https://reviews.apache.org/r/55901/#comment235703>

    Use `CHECK_SOME` instead.



src/checks/health_checker.cpp (lines 456 - 482)
<https://reviews.apache.org/r/55901/#comment235697>

    Could you please link a JIRA here?



src/checks/health_checker.cpp (line 593)
<https://reviews.apache.org/r/55901/#comment235704>

    Please keep the order of the definitions in sync with the order of declarations.



src/checks/health_checker.cpp (line 746)
<https://reviews.apache.org/r/55901/#comment235705>

    Let's pull this (together with another below) into a separate patch.



src/tests/health_check_tests.cpp (line 2107)
<https://reviews.apache.org/r/55901/#comment235706>

    Why not spelling out `cmd`?



src/tests/health_check_tests.cpp (lines 2118 - 2119)
<https://reviews.apache.org/r/55901/#comment235707>

    Why do we need to expilictly create `containerizer`?



src/tests/health_check_tests.cpp (lines 2154 - 2155)
<https://reviews.apache.org/r/55901/#comment235708>

    Formatting.
    
    Also it is probably a good idea to explicitly say you don't care about further updates.



src/tests/health_check_tests.cpp (lines 2157 - 2161)
<https://reviews.apache.org/r/55901/#comment235709>

    1. I think you can also check that task's env vars are available in the health check ->
pass exit status in the task's command.
    2. Let's avoid using obscure `populateTasks()` here. We'll get rid of it altogether in
the nearest future.



src/tests/health_check_tests.cpp (lines 2185 - 2186)
<https://reviews.apache.org/r/55901/#comment235710>

    check that `healthy` is set please.


- Alexander Rukletsov


On Feb. 2, 2017, 5:02 p.m., Gastón Kleiman wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/55901/
> -----------------------------------------------------------
> 
> (Updated Feb. 2, 2017, 5:02 p.m.)
> 
> 
> Review request for mesos, Alexander Rukletsov, Anand Mazumdar, haosdent huang, and Vinod
Kone.
> 
> 
> Bugs: MESOS-6280
>     https://issues.apache.org/jira/browse/MESOS-6280
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added support for command health checks to the default executor.
> 
> 
> Diffs
> -----
> 
>   src/checks/health_checker.hpp 95da1ff7dd6b222a93076633eb3757ec9aa43cf6 
>   src/checks/health_checker.cpp 58380dc18896f659aa9c4fb4bb567a55bba97f6b 
>   src/launcher/default_executor.cpp 97eee05cac8cb1f62d43e2aecc08a8e54e49eac3 
>   src/tests/health_check_tests.cpp 8418cd91484fd26734de16255b37f3ebf574f5eb 
> 
> Diff: https://reviews.apache.org/r/55901/diff/
> 
> 
> Testing
> -------
> 
> Introduced a new test: `HealthCheckTest.DefaultExecutorCmdHealthCheck`. It passes on
Linux, but not on macOS.
> 
> 
> Thanks,
> 
> Gastón Kleiman
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message