mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jiang Yan Xu <xuj...@apple.com>
Subject Re: Review Request 55868: Cleanups to the allocator tests.
Date Wed, 01 Feb 2017 01:27:27 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/55868/#review163768
-----------------------------------------------------------




src/tests/hierarchical_allocator_tests.cpp (line 4136)
<https://reviews.apache.org/r/55868/#comment235271>

    re Allocation vs. OfferedResources:
    
    Guangya and I chatted a bunch on /r/50868/.
    
    Seems like we can just use a single `struct Allocation` defined at the top of the file
(which you are improving here) throughout without getting into a semantic differences between
offers vs. allocation (at least right now). (In this file the choice between a OfferedResources
vs. Allocation seems arbitrary)
    
    Thoughts?


- Jiang Yan Xu


On Jan. 23, 2017, 6:31 p.m., Benjamin Mahler wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/55868/
> -----------------------------------------------------------
> 
> (Updated Jan. 23, 2017, 6:31 p.m.)
> 
> 
> Review request for mesos and Michael Park.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> This was necessary to greatly simplify the changes needed to the
> allocator tests as we introduce support for multi-role frameworks.
> 
> The main improvement here is to establish and use equality on the
> `Allocation` struct, which makes the tests more readable and avoids
> the manual probing of the allocation structure across all the tests.
> 
> 
> Diffs
> -----
> 
>   src/tests/hierarchical_allocator_tests.cpp 1edd0ecc8a93cd41532e1cf3641f67c780ab23a5

> 
> Diff: https://reviews.apache.org/r/55868/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Benjamin Mahler
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message