mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guangya Liu <gyliu...@gmail.com>
Subject Re: Review Request 55868: Cleanups to the allocator tests.
Date Thu, 26 Jan 2017 05:05:21 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/55868/#review163087
-----------------------------------------------------------




src/tests/hierarchical_allocator_tests.cpp 
<https://reviews.apache.org/r/55868/#comment234528>

    I saw that you removed all of this `ASSERT_EQ` in the following tests, any reason you
want do this?



src/tests/hierarchical_allocator_tests.cpp (line 1072)
<https://reviews.apache.org/r/55868/#comment234530>

    How about move this right before `unreserved` under #1089?



src/tests/hierarchical_allocator_tests.cpp (lines 1315 - 1316)
<https://reviews.apache.org/r/55868/#comment234540>

    How about udpate the comments here as well to hightlight `update`?
    
    ```
    // Now recover the amount of `update` resources which is equal to
    // `slave.resources()` and expect the next allocation equal to
    // `slave.resources()`.
    ```



src/tests/hierarchical_allocator_tests.cpp (line 1316)
<https://reviews.apache.org/r/55868/#comment234539>

    s/to equal/equal to



src/tests/hierarchical_allocator_tests.cpp (lines 1436 - 1438)
<https://reviews.apache.org/r/55868/#comment234541>

    How about move this right before the `update` used right before #1447 as before?



src/tests/hierarchical_allocator_tests.cpp (line 1543)
<https://reviews.apache.org/r/55868/#comment234543>

    Why not put this right before #1507 and use `allocation` for #1511 and #1522 as
    
    ```
    AWAIT_EXPECT_EQ(expected, allocation);
    ```
    
    Ditto for the following places.



src/tests/hierarchical_allocator_tests.cpp (line 4262)
<https://reviews.apache.org/r/55868/#comment234547>

    s/allocations/offers


- Guangya Liu


On 一月 24, 2017, 2:31 a.m., Benjamin Mahler wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/55868/
> -----------------------------------------------------------
> 
> (Updated 一月 24, 2017, 2:31 a.m.)
> 
> 
> Review request for mesos and Michael Park.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> This was necessary to greatly simplify the changes needed to the
> allocator tests as we introduce support for multi-role frameworks.
> 
> The main improvement here is to establish and use equality on the
> `Allocation` struct, which makes the tests more readable and avoids
> the manual probing of the allocation structure across all the tests.
> 
> 
> Diffs
> -----
> 
>   src/tests/hierarchical_allocator_tests.cpp 1edd0ecc8a93cd41532e1cf3641f67c780ab23a5

> 
> Diff: https://reviews.apache.org/r/55868/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Benjamin Mahler
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message