mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vinod Kone <vinodk...@gmail.com>
Subject Re: Review Request 55761: Fixed name matching for automatic resources.
Date Tue, 24 Jan 2017 01:47:37 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/55761/#review162753
-----------------------------------------------------------




src/slave/containerizer/containerizer.cpp (lines 73 - 74)
<https://reviews.apache.org/r/55761/#comment234061>

    What is "this list" referring to? I thought the previous comment was clear enough?



src/slave/containerizer/containerizer.cpp (line 81)
<https://reviews.apache.org/r/55761/#comment234060>

    How about
    
    // `Resources::fromString().get()` is safe because `Resources::parse()`
    // above is valid.



src/slave/containerizer/containerizer.cpp (line 82)
<https://reviews.apache.org/r/55761/#comment234062>

    s/parts/resources_/



src/slave/containerizer/containerizer.cpp (lines 85 - 88)
<https://reviews.apache.org/r/55761/#comment234065>

    s/have/has/ ? since `Resources` is an object.



src/tests/containerizer/containerizer_tests.cpp (line 20)
<https://reviews.apache.org/r/55761/#comment234068>

    new line between the two.



src/tests/containerizer/containerizer_tests.cpp (line 34)
<https://reviews.apache.org/r/55761/#comment234067>

    s/ContainerizerCommonTest/ContainerizerResourcesTest/



src/tests/containerizer/containerizer_tests.cpp (line 56)
<https://reviews.apache.org/r/55761/#comment234074>

    we typicall use camel case in mesos. here you can just do,
    
    s/expected_ports/ports/



src/tests/containerizer/containerizer_tests.cpp (lines 56 - 57)
<https://reviews.apache.org/r/55761/#comment234086>

    why not do this in one line as an assignment operator?



src/tests/containerizer/containerizer_tests.cpp (line 60)
<https://reviews.apache.org/r/55761/#comment234069>

    2 lines between tests.



src/tests/containerizer/containerizer_tests.cpp (line 62)
<https://reviews.apache.org/r/55761/#comment234080>

    s/zero/zero amount/



src/tests/containerizer/containerizer_tests.cpp (lines 75 - 76)
<https://reviews.apache.org/r/55761/#comment234088>

    see above.



src/tests/containerizer/containerizer_tests.cpp (lines 76 - 77)
<https://reviews.apache.org/r/55761/#comment234089>

    also, can you just use "stringify" here?



src/tests/containerizer/containerizer_tests.cpp (line 79)
<https://reviews.apache.org/r/55761/#comment234070>

    2 lines between tests.



src/tests/containerizer/containerizer_tests.cpp (lines 94 - 96)
<https://reviews.apache.org/r/55761/#comment234090>

    can you use stringify here?


- Vinod Kone


On Jan. 20, 2017, 1:01 p.m., Bruce Merry wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/55761/
> -----------------------------------------------------------
> 
> (Updated Jan. 20, 2017, 1:01 p.m.)
> 
> 
> Review request for mesos and Vinod Kone.
> 
> 
> Bugs: MESOS-6821
>     https://issues.apache.org/jira/browse/MESOS-6821
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Instead of doing a simple substring search for known resources like
> "cpus" to decide whether they have been explicitly specified, it now
> parses the resource string to check that a resource with that exact
> name was specified.
> 
> This splits out a fromString static member function from the start of
> Resources::parse that does parsing using either fromJSON or
> fromSimpleString and makes it available to use in
> mesos::internal::slave::Containerizer::resources.
> 
> Fixes MESOS-6821.
> 
> 
> Diffs
> -----
> 
>   include/mesos/resources.hpp c2e6d6680d9687f0bbfb73e84ffb1457072c4412 
>   src/Makefile.am 3d0e82cb522d379923e00e5e98e9c9f646fdd3db 
>   src/common/resources.cpp be9bca2063e9f0e60c5faa0142077bea56272e45 
>   src/slave/containerizer/containerizer.cpp d46882baa904fd439bffb23c324828b777228f1c

>   src/tests/containerizer/containerizer_tests.cpp PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/55761/diff/
> 
> 
> Testing
> -------
> 
> Regression test added.
> 
> 
> Thanks,
> 
> Bruce Merry
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message