mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vinod Kone <vinodk...@gmail.com>
Subject Re: Review Request 49574: Refactored /role and getRoles endpoint code.
Date Sun, 03 Jul 2016 17:32:23 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/49574/#review140562
-----------------------------------------------------------




src/master/http.cpp (line 2919)
<https://reviews.apache.org/r/49574/#comment205977>

    s/getFilteredRoles/_roles/
    
    we've been naming the common factored out functions as `_foo` in this api.



src/master/http.cpp (line 2994)
<https://reviews.apache.org/r/49574/#comment205976>

    why do you need to pull this into a variable?
    
    can't you just do 
    
    ```
    return _roles(principal)
      .then()
    
    ```



src/master/http.cpp (lines 3038 - 3040)
<https://reviews.apache.org/r/49574/#comment205980>

    ditto. just do
    
    ```
    return _roles()
      .then()
    ```


- Vinod Kone


On July 3, 2016, 4:46 p.m., Joerg Schad wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/49574/
> -----------------------------------------------------------
> 
> (Updated July 3, 2016, 4:46 p.m.)
> 
> 
> Review request for mesos and Vinod Kone.
> 
> 
> Bugs: MESOS-5709
>     https://issues.apache.org/jira/browse/MESOS-5709
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> This patch factors out common functionality of
> getting filtered/authorized roles which was
> previously duplicated between both methods.
> 
> 
> Diffs
> -----
> 
>   src/master/http.cpp 7b2f77b9264242f31ab62eb9db7c621a1b8aa2fe 
>   src/master/master.hpp be7cd239c49a0710a29a8187c01484f9f6d615e1 
> 
> Diff: https://reviews.apache.org/r/49574/diff/
> 
> 
> Testing
> -------
> 
> make (sudo) make check
> 
> 
> Thanks,
> 
> Joerg Schad
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message