mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anand Mazumdar <an...@apache.org>
Subject Re: Review Request 48511: Renamed `responseContentType` to `contentType`/`acceptType`.
Date Mon, 13 Jun 2016 23:58:10 GMT


> On June 13, 2016, 9:29 p.m., Vinod Kone wrote:
> > hmm. i dont think `responseType` is that clear. what is a http response type? type
could as well refer to status code. or maybe accept type. `responseContentType` is explicit.
> 
> Anand Mazumdar wrote:
>     hmm .. The _type_ of the variable is `ContentType`. Hence, just having the variable
name as `responseType` is _intuitive_ to the reader that this refers to the content type of
the response. That being said, looks like this reasoning might not be that obvious.
>     
>     How about just renaming it as `acceptType` to be more intuitive?
> 
> Vinod Kone wrote:
>     `acceptType` sounds good to me inside `master::Http::api()`. The handlers themselves
should call the parameter `contentType` instead of `acceptType`?

+1. Updated the diff.


- Anand


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/48511/#review137385
-----------------------------------------------------------


On June 13, 2016, 11:58 p.m., Anand Mazumdar wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/48511/
> -----------------------------------------------------------
> 
> (Updated June 13, 2016, 11:58 p.m.)
> 
> 
> Review request for mesos, haosdent huang and Vinod Kone.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> This change renames existing occurences of `responseContentType` to
> `contentType` if its a handler argument or `acceptType` inside
> `api()`, `scheduler()` and `executor()` functions in Master/Agent.
> 
> 
> Diffs
> -----
> 
>   src/master/http.cpp cd089cf6afd654b07608548f441a0e225df6425e 
>   src/master/master.hpp 2c45dab291a153b42809ab12e4252bf58559feeb 
>   src/slave/http.cpp 67ad7a92195abc266fd82fa5dc4c71f24a02aef3 
>   src/slave/slave.hpp da8b0d78af8611d22d66935e908e14977b242586 
> 
> Diff: https://reviews.apache.org/r/48511/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Anand Mazumdar
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message