mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jiang Yan Xu <...@jxu.me>
Subject Re: Review Request 44947: Add tests for XFS project quota utilities.
Date Tue, 05 Apr 2016 22:56:23 GMT


> On April 1, 2016, 12:27 a.m., Jiang Yan Xu wrote:
> > src/tests/containerizer/xfs_quota_tests.cpp, line 71
> > <https://reviews.apache.org/r/44947/diff/11/?file=1320117#file1320117line71>
> >
> >     We have 
> >     
> >     `makeQuotaInfo` vs. `mkfile` & `mkloop`. Can we make the use of the word
`make` or `mk` consistent? Generally we avoid abbreviations so using `make` (and camelCasing)
is preferred.
> 
> James Peach wrote:
>     ``mkfile`` and ``mkloop`` are named after ``mkfile(1)``, ``mknod(1)``, etc. I expected
that would be a fairly familiar nomenclature.
>     
>     ``makeQuotaInfo`` is substantially different so there's no good reason to use the
same naming scheme. It is following the ``std::make_pair`` pattern, but using Mesos naming
conventions.

SGTM!


- Jiang Yan


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/44947/#review126334
-----------------------------------------------------------


On April 4, 2016, 10:27 a.m., James Peach wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/44947/
> -----------------------------------------------------------
> 
> (Updated April 4, 2016, 10:27 a.m.)
> 
> 
> Review request for mesos, Jie Yu and Jiang Yan Xu.
> 
> 
> Bugs: MESOS-4828
>     https://issues.apache.org/jira/browse/MESOS-4828
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Add tests for XFS project quota utilities.
> 
> 
> Diffs
> -----
> 
>   src/Makefile.am f22ae5b3bd9336a56c802e0e51d39d6cb675caf2 
>   src/tests/containerizer/xfs_quota_tests.cpp PRE-CREATION 
>   src/tests/environment.cpp 90dbe9488bda6af26143934e196aab0d69dccec3 
> 
> Diff: https://reviews.apache.org/r/44947/diff/
> 
> 
> Testing
> -------
> 
> Make check. Manual testing. These tests.
> 
> 
> Thanks,
> 
> James Peach
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message