mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kapil Arya <ka...@mesosphere.io>
Subject Re: Review Request 44287: Added MasterContender and MasterDetector abstract classes.
Date Thu, 31 Mar 2016 17:25:31 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/44287/#review125914
-----------------------------------------------------------




include/mesos/master/contender.hpp (line 19)
<https://reviews.apache.org/r/44287/#comment188818>

    Please include header for `std::string`.



include/mesos/master/contender.hpp (lines 26 - 27)
<https://reviews.apache.org/r/44287/#comment188815>

    Alphabetize please!
    
    Also #include stout/try.hpp?



include/mesos/master/contender.hpp (line 65)
<https://reviews.apache.org/r/44287/#comment188820>

    I am wondering if `type` can be replaced with `moduleName` or something more explicit.



include/mesos/master/detector.hpp (line 62)
<https://reviews.apache.org/r/44287/#comment188821>

    Same as with contender, can we replace `type` with a more explicit name?


- Kapil Arya


On March 23, 2016, 7:04 p.m., Anurag Singh wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/44287/
> -----------------------------------------------------------
> 
> (Updated March 23, 2016, 7:04 p.m.)
> 
> 
> Review request for mesos, Benjamin Hindman and Kapil Arya.
> 
> 
> Bugs: MESOS-4610
>     https://issues.apache.org/jira/browse/MESOS-4610
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> MasterContender and MasterDetector abstract classes can be subclassed by
> user-provided classes to allow for arbitrary contender/detector implementations.
> 
> 
> Diffs
> -----
> 
>   include/mesos/master/contender.hpp PRE-CREATION 
>   include/mesos/master/detector.hpp PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/44287/diff/
> 
> 
> Testing
> -------
> 
> See https://reviews.apache.org/r/44670/.
> 
> 
> Thanks,
> 
> Anurag Singh
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message