mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Avinash sridharan" <avin...@mesosphere.io>
Subject Re: Review Request 41380: Added repeated vip field to DiscoveryInfo and an instance_port field to Port
Date Mon, 28 Dec 2015 18:14:38 GMT


> On Dec. 24, 2015, 11:10 a.m., Adam B wrote:
> > Looks good, but I wonder if we need to go so far as to introduce the `enum Protocol`
misnomer in the global IPAddress message now. We could always add it in later, when we actually
get NetworkInfo off of it.
> 
> Anand Mazumdar wrote:
>     1. Adam, can you elaborate a bit more on why do you think the `Protocol` field is
a misnomer here ? Are you alluding for that field to be called `version` or something else
to suit it better i.e. something like:
>     
>     ```
>     enum Version {
>       IPV4 = 1;
>       IPV6 = 2;
>     }
>     ```
>     
>     2. Also, we shouldn't worry too much about how the network isolator deals with the
`Protocol` field being set/unset, since that is relevant business logic limited to its functionality
and should not influence how the representation of `IPAddress` should look like. We should
only be concerned about wire compatibility if we intend to migrate `NetworkInfo` to use this
message later. Were you referring to the fact that just renaming `Protocol` to `Version` or
something else would make it wire incompatible with the old message inside `NetworkInfo` and
hence we should not do it now ?
>     
>     PS: I am fine with not introducing the `Protocol` field for now like you suggested.
I just wanted to be sure about the reasoning/problems with not doing it now and leaving it
off for later.

Will remove the Protocol field for the time being and set the position identifier for the
ip_address field to 2.


- Avinash


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/41380/#review111848
-----------------------------------------------------------


On Dec. 23, 2015, 3 a.m., Avinash sridharan wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/41380/
> -----------------------------------------------------------
> 
> (Updated Dec. 23, 2015, 3 a.m.)
> 
> 
> Review request for mesos, Adam B and Anand Mazumdar.
> 
> 
> Bugs: MESOS-4114
>     https://issues.apache.org/jira/browse/MESOS-4114
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added repeated vip field to DiscoveryInfo and an instance_port field to Port
> 
> 
> Diffs
> -----
> 
>   include/mesos/mesos.proto 2431fdd6b84625c6140a2b3913736bffada4e7f6 
>   include/mesos/v1/mesos.proto 4aed0980b28dc1000aa2821f35303b736bc5bff8 
> 
> Diff: https://reviews.apache.org/r/41380/diff/
> 
> 
> Testing
> -------
> 
> make check, and make
> 
> 
> Thanks,
> 
> Avinash sridharan
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message