mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Neil Conway" <neil.con...@gmail.com>
Subject Re: Review Request 40995: Added test cases for role behavior.
Date Wed, 09 Dec 2015 23:57:14 GMT


> On Dec. 8, 2015, 2:55 p.m., Alexander Rukletsov wrote:
> > src/tests/role_tests.cpp, lines 83-84
> > <https://reviews.apache.org/r/40995/diff/3/?file=1155872#file1155872line83>
> >
> >     `MesosTest` exposes the `defaultAgentResourcesString` constant. I think you
can get rid of these lines in order not to distract the user and make sure `unreserved` is
contained in `defaultAgentResourcesString` later in the code:
> >     ```
> >     EXPECT_TRUE(Resources::parse(defaultAgentResourcesString).get().contains(unreserved));
> >     ```

I looked at doing this, but I didn't feel like it was an improvement: I think it is more readable
for the test case to be explicit about the resources we expect to be available on the agent.


- Neil


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/40995/#review109324
-----------------------------------------------------------


On Dec. 9, 2015, 5:53 a.m., Neil Conway wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/40995/
> -----------------------------------------------------------
> 
> (Updated Dec. 9, 2015, 5:53 a.m.)
> 
> 
> Review request for mesos, Adam B, Alexander Rukletsov, Greg Mann, and Yong Qiao Wang.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added test cases for role behavior.
> 
> 
> Diffs
> -----
> 
>   src/Makefile.am 9762f8567e32d70b8df2d694a1fef5c692fc730e 
>   src/tests/reservation_tests.cpp eccbb8f8a02b65b26f34e020e736afe0445a6d0d 
>   src/tests/role_tests.cpp PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/40995/diff/
> 
> 
> Testing
> -------
> 
> make check.
> 
> 
> Thanks,
> 
> Neil Conway
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message