mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Rukletsov" <ruklet...@gmail.com>
Subject Re: Review Request 38161: Replaced a hard-coded number for registration backoff with a proper constant and extended comments.
Date Wed, 30 Sep 2015 15:21:18 GMT


> On Sept. 29, 2015, 7:12 p.m., Ben Mahler wrote:
> > Thanks Alex, didn't realize I was on the reviewers here, so apologies for the delay!
Why don't we just name the constant with DEFAULT to avoid the need for this and to make the
meaning of the constant more clear?

Sure, I'll rename it.


> On Sept. 29, 2015, 7:12 p.m., Ben Mahler wrote:
> > src/tests/fault_tolerance_tests.cpp, lines 620-621
> > <https://reviews.apache.org/r/38161/diff/3/?file=1085967#file1085967line620>
> >
> >     Don't think you need these comments, we should just s/REGISTRATION_BACKOFF_FACTOR/DEFAULT_REGISTRATION_BACKOFF_FACTOR/
to be more explicit about it. We've started doing this for some of our constants already,
but need to continue! :)

Yep, makes sense.


> On Sept. 29, 2015, 7:12 p.m., Ben Mahler wrote:
> > src/tests/fault_tolerance_tests.cpp, lines 1547-1551
> > <https://reviews.apache.org/r/38161/diff/3/?file=1085967#file1085967line1547>
> >
> >     Ditto here, it seems like if we use DEFAULT in the name, we don't have to bother
setting it here, thoughts?

Default `CreateSlaveFlags()` may tinker with this flag (and it actually does), therefore I
would like to restore the default value anyway to ensure we advance the clock for the correct
value.


- Alexander


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/38161/#review100993
-----------------------------------------------------------


On Sept. 28, 2015, 5:08 p.m., Alexander Rukletsov wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/38161/
> -----------------------------------------------------------
> 
> (Updated Sept. 28, 2015, 5:08 p.m.)
> 
> 
> Review request for mesos and Ben Mahler.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> See summary.
> 
> 
> Diffs
> -----
> 
>   src/tests/fault_tolerance_tests.cpp c97bc4691f9bac4a8677e6d2247be96ee9674b57 
> 
> Diff: https://reviews.apache.org/r/38161/diff/
> 
> 
> Testing
> -------
> 
> make check (Mac OS 10.10.4)
> 
> 
> Thanks,
> 
> Alexander Rukletsov
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message