mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ben Mahler" <benjamin.mah...@gmail.com>
Subject Re: Review Request 38161: Replaced a hard-coded number for registration backoff with a proper constant and extended comments.
Date Tue, 29 Sep 2015 19:12:32 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/38161/#review100993
-----------------------------------------------------------


Thanks Alex, didn't realize I was on the reviewers here, so apologies for the delay! Why don't
we just name the constant with DEFAULT to avoid the need for this and to make the meaning
of the constant more clear?


src/tests/fault_tolerance_tests.cpp (lines 620 - 621)
<https://reviews.apache.org/r/38161/#comment158295>

    Don't think you need these comments, we should just s/REGISTRATION_BACKOFF_FACTOR/DEFAULT_REGISTRATION_BACKOFF_FACTOR/
to be more explicit about it. We've started doing this for some of our constants already,
but need to continue! :)



src/tests/fault_tolerance_tests.cpp (lines 1547 - 1551)
<https://reviews.apache.org/r/38161/#comment158296>

    Ditto here, it seems like if we use DEFAULT in the name, we don't have to bother setting
it here, thoughts?


- Ben Mahler


On Sept. 28, 2015, 5:08 p.m., Alexander Rukletsov wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/38161/
> -----------------------------------------------------------
> 
> (Updated Sept. 28, 2015, 5:08 p.m.)
> 
> 
> Review request for mesos and Ben Mahler.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> See summary.
> 
> 
> Diffs
> -----
> 
>   src/tests/fault_tolerance_tests.cpp c97bc4691f9bac4a8677e6d2247be96ee9674b57 
> 
> Diff: https://reviews.apache.org/r/38161/diff/
> 
> 
> Testing
> -------
> 
> make check (Mac OS 10.10.4)
> 
> 
> Thanks,
> 
> Alexander Rukletsov
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message