mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Rukletsov" <ruklet...@gmail.com>
Subject Re: Review Request 36321: Maintenance primitives: Add Unavailability and InverseOffer protobufs.
Date Fri, 21 Aug 2015 18:35:29 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/36321/#review96073
-----------------------------------------------------------



include/mesos/mesos.proto (lines 917 - 920)
<https://reviews.apache.org/r/36321/#comment151276>

    I think the name `Unavailability` is too specific to maintenance, how about something
more generic, like `Period`?
    
    I'm thinking about a use case, when a custom allocator uses InverseOffers to ask a framework
to release resources. In this case, we need a "timeout", which is naturally expressed by `unavailability.start`.
Given we don't need duration in this case, the name can be misleading for users.


- Alexander Rukletsov


On Aug. 12, 2015, 10:07 p.m., Joseph Wu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/36321/
> -----------------------------------------------------------
> 
> (Updated Aug. 12, 2015, 10:07 p.m.)
> 
> 
> Review request for mesos, Benjamin Hindman, Ben Mahler, Artem Harutyunyan, and Joris
Van Remoortere.
> 
> 
> Bugs: MESOS-2061 and MESOS-2066
>     https://issues.apache.org/jira/browse/MESOS-2061
>     https://issues.apache.org/jira/browse/MESOS-2066
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> MESOS-2061: Add Unavailability and InverseOffer protobufs declarations.
> MESOS-2066: Add the Unavailability field to Offers.
> 
> No integration with other components (that part is tracked in separate JIRAs, see MESOS-1474).
> 
> 
> Diffs
> -----
> 
>   include/mesos/mesos.proto 8a423a56a341e380434e7df91868f1813024840c 
> 
> Diff: https://reviews.apache.org/r/36321/diff/
> 
> 
> Testing
> -------
> 
> `make check`
> 
> 
> Thanks,
> 
> Joseph Wu
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message