mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niklas Nielsen" <...@qni.dk>
Subject Re: Review Request 34631: Added QoS Controller.
Date Thu, 04 Jun 2015 01:23:49 GMT


> On June 3, 2015, 10:54 a.m., Bartek Plotka wrote:
> > include/mesos/slave/qos_controller.hpp, line 52
> > <https://reviews.apache.org/r/34631/diff/3/?file=977207#file977207line52>
> >
> >     Small thing:
> >     s/type/name/ ..to be consistent with allocator factory. (:
> >     
> >     What is the reason of naming it "type"?
> 
> Niklas Nielsen wrote:
>     It is called 'type' in the estimator as well: https://github.com/apache/mesos/blob/master/src/slave/resource_estimator.cpp#L28
>     
>     Still want me to change?
> 
> Bartek Plotka wrote:
>     I know, so resource estimator has also that potential issue.
>     
>     In fact there is a consistency issue not only in naming..
>     
>     I can see in mesos 2 approaches:
>     
>     1. Allocator and authenticator (which were earlier then RE)
>      -Defined default value if no flag. (https://github.com/apache/mesos/blob/master/src/master/flags.cpp#L349)
>      -Allocator factory gets only *const string name* (not Option<>). We don't
need to check if it's null.. (https://github.com/apache/mesos/blob/master/src/master/allocator/allocator.cpp#L37)
>     2. Your approach (and Jie Yu in https://reviews.apache.org/r/35028/diff/#)
>      -There is no default flag, but it's it catched in Option<> so it can be None()
>      -You have to check if it's None but we save space - we don't have to create default
const in constant.hpp
>        
>     To sum up - i'm fine with any of that options, however i'd love to have everything
done in the same manner (((:

Will unify in a follow up patch: https://issues.apache.org/jira/browse/MESOS-2813 dropping
issue for now :)


- Niklas


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/34631/#review86447
-----------------------------------------------------------


On June 2, 2015, 9:26 p.m., Niklas Nielsen wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/34631/
> -----------------------------------------------------------
> 
> (Updated June 2, 2015, 9:26 p.m.)
> 
> 
> Review request for mesos, Bartek Plotka, Jie Yu, and Vinod Kone.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added QoS Controller class and NOOP controller implementation
> 
> 
> Diffs
> -----
> 
>   include/mesos/slave/qos_controller.hpp PRE-CREATION 
>   src/Makefile.am f045b89e8590c4775b21980bedff14cc27d31bfb 
>   src/slave/qos_controller.hpp PRE-CREATION 
>   src/slave/qos_controller.cpp PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/34631/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Niklas Nielsen
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message