madlib-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luis Macedo <lmac...@pivotal.io>
Subject Re: Upgrade support
Date Thu, 02 Feb 2017 02:09:31 GMT
Following an upgrade chain should not be a problem if its properly
documented on the upgrade docs.





*Luis Macedo | Sr Platform Architect | **Pivotal Inc *

*Mobile:* +55 11 97616-6438
*Pivotal.io <http://pivotal.io>*
*Take care of the customers and the rest takes care of itself*

2017-02-01 22:44 GMT-02:00 Frank McQuillan <fmcquillan@pivotal.io>:

> Orhan, I think this is a reasonable approach.  Supporting upgrades for
> older versions is time consuming and probably not worth the effort at this
> point. Pus you have offered a work around.
>
> Frank
>
>
>
> On Wed, Feb 1, 2017 at 3:14 PM, Orhan Kislal <okislal@pivotal.io> wrote:
>
>> Dear MADlib community,
>>
>> I started working on the upgrade support for our upcoming release (MADlib
>> 1.10.0) and made some progress. Historically, MADlib supported upgrades
>> from any 1.x version. However, with every version, this task becomes more
>> and more time consuming. Note that all upgrades have to be tested for 6
>> platforms (last 2 versions Postgres, Greenplum and HAWQ). I believe we can
>> drop support for upgrades for versions prior to 1.8 but I wanted to
>> consult
>> with you before taking this action. This change will not disable upgrade
>> for older versions entirely. The upgrade might not give proper error
>> messages but it should still work if there are no dependencies. In
>> addition, it is possible to follow an upgrade chain 1.x -> 1.9.1 ->
>> 1.10.0.
>>
>> Please let us know if this change is not reasonable.
>>
>> Thanks
>>
>> Orhan Kislal
>>
>
>

Mime
View raw message