madlib-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rahul Iyer <rahulri...@gmail.com>
Subject Re: Installation issues: Postgres version detection in madpack + password usage
Date Thu, 09 Feb 2017 01:09:57 GMT
Thanks, Nikolay.

Looks like this time it found the "EXECUTABLE" but not the "*INCLUDE_DIR".
I'll look at this in a couple of days.

On Wed, Feb 8, 2017 at 4:27 PM, Nikolay Samokhvalov <samokhvalov@gmail.com>
wrote:

> ubuntu@box549:~/check_madlib/incubator-madlib/build$ cmake
> -DPOSTGRESQL_9_6_PG_CONFIG=/usr/bin ..
> -- Could NOT find Boost
> -- No sufficiently recent version (>= 1.47) of Boost was found. Will
> download.
> -- Could NOT find PostgreSQL_9_6 (missing:  POSTGRESQL_9_6_CLIENT_INCLUDE_DIR
> POSTGRESQL_9_6_SERVER_INCLUDE_DIR)
> -- Could NOT find Greenplum (missing:  GREENPLUM_EXECUTABLE)
> ...
>
>
> On Wed, Feb 8, 2017 at 3:52 PM, Rahul Iyer <rahulriyer@gmail.com> wrote:
>
>> Nikolay,
>>
>> The CI resources are quite useful and we'll definitely look at it. Since
>> most of the MADlib contributors are working on a pending release, we might
>> not get to this soon.
>>
>> To quickly eliminate trivial issues, could you also try `
>> -DPOSTGRESQL_9_6_PG_CONFIG=/usr/bin`?
>>
>> Thanks,
>> Rahul
>>
>> On Wed, Feb 8, 2017 at 8:50 AM, Nikolay Samokhvalov <
>> samokhvalov@gmail.com> wrote:
>>
>>> Since Postgres was installed using the very standard (for Ubuntu) way
>>> ("sudo apt-get install postgresql-9.6"), pg_config is definitely in $PATH
>>> and it works well:
>>>
>>> ubuntu@box1629:~/check_madlib/incubator-madlib/build$ pg_config
>>> BINDIR = /usr/lib/postgresql/9.6/bin
>>> DOCDIR = /usr/share/doc/postgresql-doc-9.6
>>> HTMLDIR = /usr/share/doc/postgresql-doc-9.6
>>> INCLUDEDIR = /usr/include/postgresql
>>> ...
>>> VERSION = PostgreSQL 9.6.1
>>> ubuntu@box1629:~/check_madlib/incubator-madlib/build$ which pg_config
>>> /usr/bin/pg_config
>>>
>>>
>>> Tried to point it explicitly, also doesn't work:
>>>
>>> ubuntu@box1629:~/check_madlib/incubator-madlib/build$ cmake
>>> -DPOSTGRESQL_9_6_PG_CONFIG=/usr/bin/pg_config ..
>>> -- The C compiler identification is GNU 4.8.4
>>> -- The CXX compiler identification is GNU 4.8.4
>>> -- Check for working C compiler: /usr/bin/gcc
>>> -- Check for working C compiler: /usr/bin/gcc -- works
>>> ...
>>> -- Could NOT find PostgreSQL_9_6 (missing:  POSTGRESQL_9_6_EXECUTABLE)
>>>
>>>
>>>
>>> As I've already said, it's very simple to  reproduce this situation on
>>> CircleCI -- just take my Github repo https://github.com/Nikola
>>> yS/check_madlib and add is a project at CircleCI (Github account is
>>> needed), the "Rebuild with SSH" and they will give an access to virtual
>>> host. Again, all steps to reproduce are shown here
>>> https://github.com/NikolayS/check_madlib/blob/master/circle.yml.
>>>
>>> If MADlib has some kind of CI and it checks building on Debian/Ubuntu, I
>>> can try to create building example closer to it, showing this issue with
>>> cmake and Postgres 9.6.
>>>
>>> On Wed, Feb 8, 2017 at 8:18 AM, Rahul Iyer <rahulriyer@gmail.com> wrote:
>>>
>>>> To ensure it finds postgres either:
>>>>
>>>> add `-DPOSTGRESQL_9_6_PG_CONFIG=/path/to/pg_config' with the `cmake
>>>> ...` command
>>>> or
>>>> ensure the postgresql bin directory is in your $PATH
>>>>
>>>> On Tue, Feb 7, 2017 at 6:53 PM, Nikolay Samokhvalov <
>>>> samokhvalov@gmail.com> wrote:
>>>>
>>>>> You're right:
>>>>>
>>>>>    -- Could NOT find PostgreSQL (missing: POSTGRESQL_EXECUTABLE)
>>>>>
>>>>> Full output: https://circleci.com/gh/NikolayS/check_madlib/7
>>>>>
>>>>> On Tue, Feb 7, 2017 at 6:47 PM, Orhan Kislal <okislal@pivotal.io>
>>>>> wrote:
>>>>>
>>>>>> Hi Nikolay,
>>>>>>
>>>>>> What was the output when you called the cmake? I suspect it did not
>>>>>> recognize 9.6.1 but I just want to be sure.
>>>>>>
>>>>>> Thanks
>>>>>>
>>>>>> Orhan
>>>>>>
>>>>>> On Tue, Feb 7, 2017 at 6:18 PM, Nikolay Samokhvalov <
>>>>>> samokhvalov@gmail.com> wrote:
>>>>>>
>>>>>>> Thank you for your answer.
>>>>>>>
>>>>>>> This is what I get when I install the current version from git
(git
>>>>>>> clone git@github.com:apache/incubator-madlib.git):
>>>>>>>
>>>>>>> madpack.py : INFO : Detected PostgreSQL version 9.6.
>>>>>>> madpack.py : ERROR : This version is not among the PostgreSQL
>>>>>>> versions for which MADlib support files have been installed ().
>>>>>>>
>>>>>>>
>>>>>>> On Tuesday, February 7, 2017, Orhan Kislal <okislal@pivotal.io>
>>>>>>> wrote:
>>>>>>>
>>>>>>>> Hi Nikolay,
>>>>>>>>
>>>>>>>> Postgres 9.6 is not supported by MADlib v1.9.1 binaries.
The error
>>>>>>>> message is saying that only 9.4 and 9.5 are supported. We
have added
>>>>>>>> Postgres 9.6 support to the source code and it should be
available with our
>>>>>>>> next release. You might want to try building the development
version of
>>>>>>>> MADlib from source and install that if you don't want to
wait for v1.10.0.
>>>>>>>> Here is our wiki to help you get started: https://cwiki.apache.
>>>>>>>> org/confluence/display/MADLIB/Installation+Guide
>>>>>>>>
>>>>>>>> Thanks
>>>>>>>>
>>>>>>>> Orhan
>>>>>>>>
>>>>>>>> On Tue, Feb 7, 2017 at 4:39 PM, Nikolay Samokhvalov <
>>>>>>>> samokhvalov@gmail.com> wrote:
>>>>>>>>
>>>>>>>>> Hello,
>>>>>>>>>
>>>>>>>>> I'm experiencing new issues with installation on Ubuntu
machine.
>>>>>>>>>
>>>>>>>>> I have Postgres 9.6.1 (only) installed, but when I'm
trying to run
>>>>>>>>> madpack, I get:
>>>>>>>>>
>>>>>>>>> madpack.py : INFO : Detected PostgreSQL version 9.6.
>>>>>>>>> madpack.py : ERROR : This version is not among the PostgreSQL
>>>>>>>>> versions for which MADlib support files have been installed
(9.5, 9.4).
>>>>>>>>>
>>>>>>>>> Neither 9.4, nor 9.5 are not installed on the machine,
only 9.6:
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> ubuntu@box450:~$ dpkg -l | grep postgresql
>>>>>>>>> ii  pgdg-keyring                             2014.1
>>>>>>>>>                   all          keyring for apt.postgresql.org
>>>>>>>>> ii  postgresql-9.6                           9.6.1-2.pgdg14.04+1
>>>>>>>>>                  amd64        object-relational SQL database,
version 9.6
>>>>>>>>> server
>>>>>>>>> ii  postgresql-client-9.6                    9.6.1-2.pgdg14.04+1
>>>>>>>>>                  amd64        front-end programs for
PostgreSQL 9.6
>>>>>>>>> ii  postgresql-client-common                 178.pgdg14.04+1
>>>>>>>>>                  all          manager for multiple PostgreSQL
client
>>>>>>>>> versions
>>>>>>>>> ii  postgresql-common                        178.pgdg14.04+1
>>>>>>>>>                  all          PostgreSQL database-cluster
manager
>>>>>>>>> ii  postgresql-contrib-9.6                   9.6.1-2.pgdg14.04+1
>>>>>>>>>                  amd64        additional facilities for
PostgreSQL
>>>>>>>>> ii  postgresql-plpython-9.6                  9.6.1-2.pgdg14.04+1
>>>>>>>>>                  amd64        PL/Python procedural language
for PostgreSQL
>>>>>>>>> 9.6
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> So it looks like MADlib incorrectly detects version of
Postgres
>>>>>>>>> available .
>>>>>>>>>
>>>>>>>>> Everything is happening on a CirlceCI virtual machine,
so anyone
>>>>>>>>> who has Github account can see it easily and repeat /
debug right there:
>>>>>>>>> https://circleci.com/gh/NikolayS/check_madlib/5
>>>>>>>>>
>>>>>>>>> Here is a list of all steps to reproduce: https://github.com/
>>>>>>>>> NikolayS/check_madlib/blob/master/circle.yml
>>>>>>>>>
>>>>>>>>> .deb package was created using RPM package. I get the
same results
>>>>>>>>> if I try to install MADlib from source on that Ubuntu
machine.
>>>>>>>>>
>>>>>>>>> I have no experience with cmake, so please help.
>>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>
>>>>>
>>>>
>>>
>>
>

Mime
View raw message