madlib-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frank McQuillan <>
Subject Re: Upgrade support
Date Thu, 02 Feb 2017 00:44:20 GMT
Orhan, I think this is a reasonable approach.  Supporting upgrades for
older versions is time consuming and probably not worth the effort at this
point. Pus you have offered a work around.


On Wed, Feb 1, 2017 at 3:14 PM, Orhan Kislal <> wrote:

> Dear MADlib community,
> I started working on the upgrade support for our upcoming release (MADlib
> 1.10.0) and made some progress. Historically, MADlib supported upgrades
> from any 1.x version. However, with every version, this task becomes more
> and more time consuming. Note that all upgrades have to be tested for 6
> platforms (last 2 versions Postgres, Greenplum and HAWQ). I believe we can
> drop support for upgrades for versions prior to 1.8 but I wanted to consult
> with you before taking this action. This change will not disable upgrade
> for older versions entirely. The upgrade might not give proper error
> messages but it should still work if there are no dependencies. In
> addition, it is possible to follow an upgrade chain 1.x -> 1.9.1 -> 1.10.0.
> Please let us know if this change is not reasonable.
> Thanks
> Orhan Kislal

View raw message