madlib-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Orhan Kislal <>
Subject Upgrade support
Date Wed, 01 Feb 2017 23:14:49 GMT
Dear MADlib community,

I started working on the upgrade support for our upcoming release (MADlib
1.10.0) and made some progress. Historically, MADlib supported upgrades
from any 1.x version. However, with every version, this task becomes more
and more time consuming. Note that all upgrades have to be tested for 6
platforms (last 2 versions Postgres, Greenplum and HAWQ). I believe we can
drop support for upgrades for versions prior to 1.8 but I wanted to consult
with you before taking this action. This change will not disable upgrade
for older versions entirely. The upgrade might not give proper error
messages but it should still work if there are no dependencies. In
addition, it is possible to follow an upgrade chain 1.x -> 1.9.1 -> 1.10.0.

Please let us know if this change is not reasonable.


Orhan Kislal

View raw message