madlib-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nurur Rahman <nurur_rah...@glic.com>
Subject RE: MADlib's Random Forest Classification and Regression Example
Date Wed, 13 Jul 2016 19:40:18 GMT
Frank, really appreciate for looking at it.
I believe for our system it runs on Linux. This is the output of “select version()” and
“select madlib.version()”

"PostgreSQL 8.2.15 (Greenplum Database 4.2.0 build 1)
(HAWQ 1.3.0.0 build 12954) on x86_64-unknown-linux-gnu,
compiled by GCC gcc (GCC) 4.4.2 compiled on Mar 25 2015 12:36:53"

"MADlib version: 1.9, git revision: rc/v1.9-rc1,
cmake configuration time: Thu Apr  7 18:43:03 UTC 2016,
build type: Release,
build system: Linux-2.6.18-238.27.1.el5.hotfix.bz516490,
C compiler: gcc 4.4.0, C++ compiler: g++ 4.4.0"

Thanks.
Nurur

From: Frank McQuillan [mailto:fmcquillan@pivotal.io]
Sent: Wednesday, July 13, 2016 3:33 PM
To: user@madlib.incubator.apache.org
Subject: Re: MADlib's Random Forest Classification and Regression Example

Hi Nurur,

Thanks for the question.  I just re-ran those examples on my local machine on a recent version
of Postgres and they seemed to work fine for me.

Your email says:

"PostgreSQL 8.2.15
(Greenplum Database 4.2.0 build 1)
(HAWQ 1.3.0.0 build 12954)"

Which platform did you see the error on?

Frank




On Wed, Jul 13, 2016 at 8:07 AM, Nurur Rahman <nurur_rahman@glic.com<mailto:nurur_rahman@glic.com>>
wrote:
Hello,
I am going through Random Forest example given in MADlib's User Documentation:
http://madlib.incubator.apache.org/docs/latest/group__grp__random__forest.html#examples

In both cases when I run “SELECT madlib.forest_train( … … )” exactly as it is shown
in
steps 1 and 2 in the example page, I get the following error:

ERROR:  plpy.SPIError: Function "madlib._dt_apply(madlib.bytea8,madlib.bytea8,madlib.bytea8,smallint,smallint,smallint,boolean,integer)":
Invalid type conversion. Simple type supplied but backend expects composite type. (plpython.c:4648)
CONTEXT:  Traceback (most recent call last):
  PL/Python function "forest_train", line 39, in <module>
    sample_ratio
  PL/Python function "forest_train", line 553, in forest_train
  PL/Python function "forest_train", line 2192, in _tree_train_using_bins
  PL/Python function "forest_train", line 1162, in _one_step
PL/Python function "forest_train"



Relevant Info:
"PostgreSQL 8.2.15
(Greenplum Database 4.2.0 build 1)
(HAWQ 1.3.0.0 build 12954)

"MADlib version: 1.9, git revision: rc/v1.9-rc1


Can anyone please explain what the reasons behind this error message? Your help will be appreciated.


Thanks.
Nurur
________________________________
----------------------------------------- This message, and any attachments to it, may contain
information that is privileged, confidential, and exempt from disclosure under applicable
law. If the reader of this message is not the intended recipient, you are notified that any
use, dissemination, distribution, copying, or communication of this message is strictly prohibited.
If you have received this message in error, please notify the sender immediately by return
e-mail and delete the message and any attachments. Thank you.



-----------------------------------------
This message, and any attachments to it, may contain information that is privileged, confidential,
and exempt from disclosure under applicable law.  If the reader of this message is not the
intended recipient, you are notified that any use, dissemination, distribution, copying, or
communication of this message is strictly prohibited.  If you have received this message in
error, please notify the sender immediately by return e-mail and delete the message and any
attachments.  Thank you.
Mime
View raw message