lucenenet-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Meyers <Aaron.Mey...@microsoft.com.INVALID>
Subject Build error on LuceneDocsPlugin: target "pack" does not exist
Date Fri, 05 Jul 2019 22:15:45 GMT
Hi all,

I'm trying to build the current Lucene.Net sources locally and I'm running into the following
build error:

C:\Data\github\lucenenet\src\docs\LuceneDocsPlugins\LuceneDocsPlugins\LuceneDocsPlugins.csproj
: error MSB4057: The targ
et "pack" does not exist in the project.
Error: 7/5/2019 3:00:22 PM:
 +                 ~~~~~& dotnet.exe pack $project --configuration $Configuration --output
$nuget_package_directory --no
-build --include.symbols /p:PackageVersion=$packageVersion

I've poked around a little bit and haven't figured out what is going on - has anyone else
run into this?
My machine has multiple versions of VS (2015/2017/2019) and .NET Core SDKs (2.0 through 3.0
preview) so it might have something to do with that. It was trying to build using the 3.0
preview SDK which overrode with global.json in the lucenenet repo root but no effect on this
build error.

Thanks!


Aaron Meyers
Principal Software Engineer
Microsoft Power BI


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message